Zitierung nach Randnummer - ohne Klammern

Franziskus B. hinzugefügt 2 Jahren her
beantwortet

Hallo,

ich habe ein Problem mit der Zitierung von Beiträgen in Sammelwerken, die nicht nach Seiten, sondern nach § oder Art. und Rn. zitiert werden.

Die Ausgabe sollte in etwa so aussehen Müller, in: XYZ, § 1 Rn. 1. Allerdings sieht mein Zitationsstil (auch so gewollt) vor, dass die zitierte Seite normalerweise in Klammern steht. Daher wird, wenn ich statt einer Seite, eine Rn. einfüge, Müller, in XYZ, § 1 (Rn. 1) ausgegeben. Gibt es eine Möglichkeit, diese Klammern in diesen Fällen zu eliminieren?

Vielen Dank schon einmal

Franz

Kommentare (1)

Foto
1

Hallo Franz

Sie können drei Wege gehen:

a) Sie fügen die Referenz in Citavis Word Add-in mit der Option "Keine Klammern" ein.

b) Sie ergänzen in Ihrem Zitationsstil eine Vorlage, die dann greift, wenn Sie die Quelle "Mit Option 1" einfügen. In dieser Vorlage würden Sie die Klammern entfernen.

c) Sie ergänzen in Ihrem Zitationsstil eine Vorlage, die dann greift, wenn der Seitenzahl-Typ "Randnummer" ist. In dieser Vorlage würden Sie die Klammern entfernen. Ein passendes Skript dazu müsste jedoch erst programmiert werden.

Freundliche Grüsse

Peter

Foto
1

Ich glaube, das ist alles zu kompliziert gedacht. Laut Beschreibung sind die Klammern momentan nur um die Seitenzahl des Zitatseitenbereichs, nicht um den ganzen Nachweis, man muss also nur in der entsprechenden Komponente einstellen, dass die Klammern nicht erscheinen, falls der der Seitenzahl-Typ “Randnummern” ist.

Foto
1

Stimmt!

/056d9c59ec0e95e3ca649ec710c89a76

und ...

/721b82edfdd0262bf81215402a54da39

Danke fürs Geraderücken.

Freundliche Grüsse

Peter

Foto
1

Vielen Dank! Das hat soweit geklappt mithilfe der Lösung b). Den Tipp von Jan konnte ich nicht anwenden, da die Klammern eigene Textelemente sind - danke trotzdem!

Allerdings habe ich ein weiteres Problem: Bei der Zitierung nach Randnummern wird, auch wenn nur genau eine Rn. zitiert wird, immer ein ff. ausgegeben. Bei den Einstellungen der Komponente scheint aber eigentlich alles zu stimmen. Wo könnte der Fehler liegen?

9b1724407d5e2ff2647ca4839287f84d

Foto
1

Hallo Franziskus

Das sieht alles gut aus. Um zu prüfen, wo die Problemursache genau liegt, senden Sie mir bitte ein Beispiel-Dokument. Sie würden dazu eine neue Word-Datei mit Ihrem Citavi-Projekt verknüpfen, Ihren Zitationsstil auswählen und über das Word Add-In diejenigen Titel in das Word-Dokument einfügen, bei denen Sie Probleme beobachtet haben. Senden Sie mir auch Ihren selbst erstellten Zitationsstil zu. Sie finden die Datei im Ordner Documents\Citavi 6\Custom Citation Styles.

Laden Sie die Dateien am besten über http://www.citavi.com/transfer hoch und geben Sie in das Notizfeld die Nummer 64702 ein, damit wir die Daten Ihrer Anfrage zuordnen können.

Freundliche Grüsse

Peter

Foto
1

Ich will ja niemandem zu seinem Glück zwingen, aber "da die Klammern eigene Textelemente sind". Warum? Warum nicht die Textelemente löschen, und die Klammern in Prä- und Suffix schreiben?

So wie es jetzt ist, muss man immer von Hand daran denken, die Option 1 auch zu setzen, statt das Citavi automatisch entscheidet, ob es anhand des Seitentyps Klammern setzen muss oder nicht.

Foto
1

Hallo Peter, hallo Jan,

es funktioniert jetzt, das unnötige ff. erscheint nicht, wenn ich bei den Einfüge-Optionen im Word-Add-In als Zahlenformat noch einmal "Arabische Zahlen" auswähle. Bisher hatte ich das Zahlenformat nur bei den Einstellungen der Komponente "Zitat-Seiten" als arabisch festgelegt. (Hätte das nicht eigentlich reichen sollen? Wie auch immer, es geht ja jetzt.)

@Jan: Die Klammern als eigene Textelemente habe ich eingebaut, um ein anderes Problem zu lösen (siehe hier: https://help.citavi.com/topic/zitat-der-ersten-seite-eines-zeitschriftenaufsatzes). Ansonsten hätte ich wohl auf deine Lösung zurückgegriffen.

Vielen Dank euch beiden!

Foto
1

Wenn das Skript tatsächlich erfordert, dass die Klammern in eigenen Elementen stehen sollte man das Skript überarbeiten, das macht die Sache für Nutzer ja nur grundlos kompliziert.

Foto
1

Ich hab mir den verlinkten Thread aus dem alten Forum jetzt mal durchgelesen. Das Problem des Skriptes ist offenbar, dass es im Fall eines mehrseitigen Seitenbereiches, bei dem die Startseite identisch mit der Startseite des Aufsatzes ist, das Suffix des Zitatseitenbereichs übernimmt, ohne die schließende Klammer zu löschen. Das verallgemeinerungsfähig für alle Paare zu lösen ist nicht ganz einfach, aber einfach drauf zu testen, ob das Suffix eine schließende Klammer hat, und das Präfix eine öffnende, und in dem Fall die schließende Klammer zu löschen, ist nicht so kompliziert. Das wäre vielleicht eine Ergänzungsoption für das Skript, damit der Nutzer keine Umwege mit irgendwelchen Optionsschaltern gehen muss. Und das Skript ist ja eigentlich so beschrieben, als ob das jetzt schon funktionieren sollte (oben im Kommentar, unter [4]), ohne irgendwelche Verrenkungen mit Textelementen und Optionsschaltern machen zu müssen.

Foto
1

Auf Anregung von JJ hat mein Kollege das Skript optimiert.

Freundliche Grüsse

Peter

Foto
Antwort schreiben
 
Dateianlage anfügen (KEINE vertraulichen Dokumente!)