Zeichenlimit im Citavi Word Add-in im Feld "Seiten von-bis"

David S. hinzugefügt 13 Monaten her
beantwortet

Hallo :),

Ich versuche gerade über das Word Add-in einen Quellennachweis im Text einzufügen.

Als Zitationsstil nutze ich DIN ISO 690 (kopiert und die Funktion f. und ff. hinzugefügt.)

Nun möchte ich einem Quellennachweis den Seitenzahlenbereich 498-548 hinzufügen. Leider erkennt das Plugin ab der 7. Ziffer keinen Zahlenbereich mehr. In diesem Fall habe ich im Feld "Seiten von-bis" 498-548 stehen und im Dokument wird mit S. 498 angezeigt.

Wenn ich nun in das Feld 498-54 eintrage (auch wenn es keinen Sinn ergibt) erhalte ich im Dokument S. 498-54. Der Zahlenbereich wird also erkannt, ist aber nun mal nicht der richtige.

Citavi sollte doch auch mit Größeren Seitenzahlen umgehen können... Es gibt ja auch Bücher mit >1000 Seiten.

Citavi und Word Add-in sind beide V6.1.0.0


Kann ich dieses Problem beheben oder umgehen?

Den Nachweis von Hand eintragen sollte das letzte mögliche Mittel sein :)

Beste Antwort
Foto

Hallo David,

vielen Dank für die zugesandten Dateien. Ich habe Ihnen auch gerade per Mail geantwortet.

Für Mitleser & -tüftler: Tatsächlich war eine Einstellung bei der Zitatseiten-Komponente nicht korrekt: Dort war unter "Zahlenformat" die Option "Arabisch (z.B. 153)" gewählt. Bitte nutzen Sie hier stattdessen die Option "Kein Zahlensystem (Ausgabe wie Eingabe)".

In Citavis Word Add-in wählen Sie bitte dennoch unter "Zahlensystem" die Option "Arabische Zahl", damit auch das Präfix wie gewünscht erscheint. (Normalerweise müssen Sie das nicht manuell vornehmen, sondern nur dann, wenn das Zahlensystem automatisch umgestellt wurde, etwa weil Sie als Zahlenbereich zunächst nur die Anfangsseite und den Bindestrich eingetragen und die Endseite erst später ergänzt haben.)

Viele Grüße

Susanne

Kommentare (4)

Foto
1

Und wenn der Seitenbereich "42-48" ist, wird dann mehr als nur die Startseite ausgegeben? Denn Ockhams Rasiermesser würde mir hier ohne weitere Informationen nahelegen, dass da was mit dem Hinzufügen der Funktion f. und ff. nicht geklappt hat. "498-54" klappt dann, weil das nicht als Seitenbereich erkannt wird und somit komplett ausgegeben wird.

Foto
1

Hallo David,

vielen Dank für Ihre Frage.

Mit der Originalversion des Zitationsstils konnte ich den beschriebenen Fehler nicht reproduzieren.

Prüfen Sie bitte, ob Sie die Zitatseiten-Komponente wie auf der folgenden Handbuchseite beschrieben eingerichtet haben:

https://www1.citavi.com/sub/manual6/de/index.html?cse_page_numbers.html

Falls Sie übrigens Seitenbereiche mit genau drei Seiten mit ff. abkürzen und längere Seitenbereiche vollständig ausgeben möchten, können Sie an die Zitatseiten-Komponente das folgende Skript anhängen (die Version für Citavi 5 funktioniert auch mit Citavi 6):

https://service.citavi.com/kb/a727/431521-seitenzahlbereich-abkuerzen-der-3-seiten-umfasst.aspx

Viele Grüße

Susanne

Foto
1

Hallo Jan,

Danke für deinen Hinweis. Hier irgendwo war bzw. ist ein Bug....

Leider kann ich nicht erkennen wann genau und aus welchem Grund der Zahlenbereich nicht erkannt wird. (Das Problem trat also auch bei 42-48 auf) Hatte irgendwie nicht gedacht, dass Citavi den Zahlenbereich tatsächlich validiert^^.

Im Zitationseditor habe ich keine Unstimmigkeit gefunden. Als ich aber im Zitationseditor den entsprechenden Dialog geöffnet hatte (ohne etwas zu ändern) habe ich im Word Dokument nochmal die Zahlen geändert, um nochmal ein Gefühl für das Problem zu bekommen und zack. Es funktionierte richtig. Sowohl Eine Seite als auch 2 Seiten (f.), 3 Seiten (ff.) und auch ein größerer Bereich.

Nach dem Schließen des Zitationseditors war das Problem wieder da. Hier habe ich dann im Citavi Add-in das Zahlensystem einmal geändert (oder nochmal Arabisch angeklickt) und der Fehler war wieder weg.

Ich kann also nicht ganz sagen, wo dieser Fehler produziert wird. Aber eben durch das Zahlensystem lässt sich dieser "beheben".

Die Funktion für f. lässt sich ja ohne weiteres hinzufügen. Für ff. habe ich folgendes Makro verwendet: https://service.citavi.com/kb/a727/431521-seitenzahlbereich-abkuerzen-der-3-seiten-umfasst.aspx


ps.: Toll dieses Ockhams Rasiermesser :D


Edit: Susannes Antwort habe ich nicht sehen können, da ich mit dem Verfassen dieser Antwort beschäftigt war :)

Foto
1

Hallo David,

vielen Dank für Ihre Rückmeldung.

Um zu prüfen, wo die Problemursache genau liegt, senden Sie mir bitte ein Beispiel-Dokument (max. 3 Seiten).

Sie würden dazu eine neue Word-Datei mit Ihrem Citavi-Projekt verknüpfen, Ihren Zitationsstil auswählen und über das Word Add-In diejenigen Titel in das Word-Dokument einfügen, bei denen Sie Probleme beobachtet haben. Diese Referenzen stehen dann für den IST-Zustand. In das Word-Dokument ergänzen Sie bitte von Hand den SOLL-Zustand.

Da Sie einen selbst erstellten Stil nutzen, senden Sie uns den Stil auch zu. Sie finden die Datei im Ordner Documents\Citavi 6\Custom Citation Styles.

Die Dateien senden Sie bitte über unser Upload-Formular http://www.citavi.com/transfer. Bitte verwenden Sie dieselbe Mail-Adresse wie für die ursprüngliche Anfrage an uns und geben Sie dort im Fenster "Nachricht" diese Bearbeitungsnummer ein: #48969.

Viele Grüße

Susanne

Foto
1

Hallo Susanne,

ich habe beide Dateien abgeschickt.

Wollte aber noch erwähnen, dass unter der Überschrift "Ist-Zustand" nur das letzte Beispiel fehlerhaft ist.

Ich weiß nicht, ob bei den anderen Beispielen der Fehler auch irgendwann in irgendeiner form auftreten würde. Bei dem Beispiel für mehr als drei Seiten habe ich eher durch Zufall das Problem reproduziert bekommen.

Vielen Dank schonmal

David

Foto
1

Hallo David,

vielen Dank für die zugesandten Dateien. Ich habe Ihnen auch gerade per Mail geantwortet.

Für Mitleser & -tüftler: Tatsächlich war eine Einstellung bei der Zitatseiten-Komponente nicht korrekt: Dort war unter "Zahlenformat" die Option "Arabisch (z.B. 153)" gewählt. Bitte nutzen Sie hier stattdessen die Option "Kein Zahlensystem (Ausgabe wie Eingabe)".

In Citavis Word Add-in wählen Sie bitte dennoch unter "Zahlensystem" die Option "Arabische Zahl", damit auch das Präfix wie gewünscht erscheint. (Normalerweise müssen Sie das nicht manuell vornehmen, sondern nur dann, wenn das Zahlensystem automatisch umgestellt wurde, etwa weil Sie als Zahlenbereich zunächst nur die Anfangsseite und den Bindestrich eingetragen und die Endseite erst später ergänzt haben.)

Viele Grüße

Susanne

Foto
1

Super Vielen Dank!


Jetzt müsste man nur noch den Tag von "nicht reproduzierbar" auf "gelöst" ändern :)

Foto
2

Hallo David,

gern geschehen und vielen Dank für Ihre Antwort!

Weil es sich nicht um einen Bug handelt, habe ich mir erlaubt, den Typ des Threads in "Frage" und den Status auf "beantwortet" zu ändern.

Viele Grüße

Susanne

Foto