Suche nach großgeschriebenen Buchstaben+Ziffern/Zahlen im Kategorien-Fenster

Felix S. hinzugefügt 2 Monaten her
in Arbeit

Liebes Citavi-Team,


Ich möchte im Kategorien-Formular nach Ziffern/Zahlen in Kombination mit Buchstaben suchen (z.B. DH IV 13). Sie hatten mir in dieser Angelegenheit schon einmal geholfen (https://support.citavi.com/forum/viewtopic.php?f=163&t=16164) und mir erklärt, dass das i.d.R. über die Tastenkombination "RX_[gewünschte Zahl eingeben]" funktioniert.

Diese Tastenkombination funktioniert ist inzwischen nur noch nötig, wenn ich das "Kategorien zuweisen"-Fenster bei Wissenselementen öffne oder in der Literaturverwaltung oder Wissensorganisation direkt aus den jeweiligen großen Listen heraus etwas suche.

Dann funktioniert die kombinierte Suche nach einer Buchstaben- und Zahlenfolge, z.B. nach "ABC 123" mit "ABC RX_123" zuverlässig.

Wenn ich allerdings ein Wissenselement in einem separaten Fenster geöffnet habe und unten in der Kategorien-Leiste direkt nach einer Kategorie suche und sie hinzufüge, funktioniert die Suche ganz einfach ohne, dass ich "RX_" einbauen müsste. Nun kommt es aber genau hierbei zu einem kuriosen Fehler, wenn die Buchstabenfolge großgeschrieben wird. Wenn ich z.B. nach "abc 123" suche, finde ich die entsprechende Kategorie, wenn ich allerdings nach "ABC 123" suche, ist die Suche erfolglos, selbst wenn es eine exakt so großgeschriebene Kategorie "ABC 123" gibt. Dann hilft auch der Umweg über "RX_" nichts.


Können Sie diesen Fehler irgendwie nachvollziehen und reproduzieren und wenn möglich gar beheben?

Herzliche Grüße,


Felix

Kommentare (4)

Foto
1

Hallo, Felix

ich kann das in der aktuellen Alpha-Version nicht mehr reproduzieren, zumindest nicht vollständig. Die "Gehe zu..."-Schnellsuche verhält sich im Zusammenhang mit Zahlen am Ende nach wie vor ungewöhnlich. Im Editor für die Wissenselemente klappt es aber:

50b0663d209079b80a18b2c0a8a5b71b


Verhält es sich bei Ihnen anders?

Viele Grüße

Sebastian

Foto
1

Hallo Sebastian,

bei mir verhält es sich im Editor für die Wissenselemente genauso wie in den "Gehe zu"-Suchfeldern.

Als Workaround reicht es im Moment aber einfach alles mit Kleinbuchstaben zu suchen und bei der Suche über "Gehe zu" eben wie bisher ein "RX_" vor die Zahl zu setzen.

Längerfristig wäre es toll, wenn die Suchfelder alle gleich gut funktionieren. Wann ist denn mit einem Release der nächsten Beta zu rechnen?

Viele Grüße,

Felix

Foto
1

Hallo, Felix

ich kann das geschilderte Verhalten in Version 6.3.6 auch reproduzieren. Ein Bugticket für die "Gehe zu"-Suche habe ich bereits erfasst. Einen konkreten Erscheinungstermin für die Beta-Version kann ich Ihnen leider nicht nennen, allzu lang wird es aber hoffentlich nicht mehr dauern.

Viele Grüße

Sebastian

Foto
Foto
1

Hallo Sebastian,


ich habe kürzlich die neue Beta 6.3.11 installiert und freue mich über die verbesserte Performance, leider hat sich die Suche nach Zahlen eher verschlechtert. Inzwischen funktioniert die Suche weder wenn ich ein Wissenselement in einem separaten Fenster geöffnet habe und unten in der Kategorien-Leiste direkt nach einer Kategorie suche, noch wenn ich den Kategorienbaum aus einem Wissenselement über "Kategorien zuweisen" öffne und dort über die "Gehe zu"-Leiste suche. In beiden Fällen funktioniert die Suche nach einer dreistelligen Ziffer weder mit noch ohne "RX_". Können Sie den Fehler reproduzieren oder funktioniert die Zahlensuche in Citavi inzwischen völlig anders?

Viele Grüße,

Felix

Foto
1

Hallo, Felix

Könnten Sie mir bitte noch einen Screenshot von der Suche und dem fehlerhaften und dem gewünschten Ergebnis schicken. Es scheint hier tatsächlich etwas nicht zu stimmen, denn den folgenden Treffer in der aktuellen Betaversion 6.3.11 kann ich mir nicht erklären:


/c36d09bb0ffeffdb40e91f6ec76dcf7c

Vielen Dank für die Mithilfe.

Viele Grüße

Sebastian

Foto
1

Hallo Sebastian,


ich habe ein paar Screenshots angefertig: Manchmal funktioniert es wie erwünscht (Bild 1), manchmal findet es manches, aber nicht alles (Bild 2: die ausgewählte/angekreuzte Kategorie wird nicht gefunden), manchmal spuckt das Feld zu viele Treffer aus bzw. zeigt Kategorien an, die den gesuchten Ausdruck gar nicht enthalten (Bilder 3).

Ich hoffe, das hilft Ihnen weiter und würde mich freuen, wenn Sie mir sagen könnten, falls ein Beta-Release, die Suchfunktion repariert!

Viele Grüße,


Felix

Foto
1

Hallo, Felix

Könnten Sie mir Ihr Kategoriensystem für weitere Tests zur Verfügung stellen?

Zum Übermitteln der Datei(en) verwenden Sie bitte unsere geschützte Upload-Möglichkeit:http://www.citavi.com/transfer

Vielen Dank und viele Grüße

Sebastian

Foto
1

Hallo Sebastian,

vielen Dank für Ihre Antwort! In welchem Format soll ich das Kategoriensystem denn exportieren und hochladen: Microsoft Word, Writer, ConceptDraw, FreeMind oder Mindjet MindManager Pro?

Viele Grüße,

Felix

Foto
1

Hallo, Felix,

das ist für diesen Zweck ganz egal.

Viele Grüße

Sebastian

Foto
1

Hallo, Felix,

vielen Dank für das Kategoriensystem. Bei meinen Tests mit der aktuellen Alpha-Version eben hat die Suche wie erwartet funktioniert (auch bei "Pippin dk 16"), aber insgesamt ist Ihr System eine Nummer zu groß für das Programm. Wir werden die Suche hier aber im Auge behalten.

Viele Grüße

Sebastian

Foto
1

Hallo Sebastian,


vielen Dank für die Antwort. Dass mein Kategorienbaum zu groß ist, ist mir bewusst, leider ist ein Umsteigen auf Schlagwörter im Rahmen dieses Projekts nicht mehr möglich. Was Ihren Testlauf anbelangt: Ich habe es soeben nochmal mit "Pippin dk 16" probiert und bekomme zwar einen Treffer, aber nur diesen und nicht den gewünschten (im Screenshot angekreuzt), der denselben Ausdruck enthälft. Habe ich etwas übersehen?

Viele Grüße,

Felix

Foto
1

Hallo, Felix

Das ganze ist und bleibt leider sonderbar. Ich habe es gerade nochmals mit Ihrem Kategoriensystem und "Pippin dk 16" versucht - weder in der linken Ansicht noch in der Kategorienliste bekomme ich jetzt einen Treffer. Wir bleiben dran.

Viele Grüße

Sebastian

Foto