< i >...< /i > in Titelliste

Max R. hinzugefügt 2 Jahren her
gelöst

In der Titelliste wird mit bei manchen Titeln die Kursivschreibung enthalten anstelle der kursiven Buchstaben der entsprechende Tag in Klartext angezeigt - also <i> XYZ </i> - siehe Attachment


Es hilft dabei dann auch nicht, die Formatierung zu entfernen (zur Sicherheit für den gesamten Titel, damit nichts versteckt übrig bleibt) - wenn man danach wieder kursiv setzt tauchen die Tags wieder auf. Die anderen Tags (fett, hoch-, tiefgestellt verhalten sich in dem Fall genau so)


Soweit ich sehen kann ist das allerdings nur in der Titelliste so - im Titelfeld des Titelreiters, im "aktuellen Titel im Zitationsstil", so wie in den eigentlichen Zitaten in Word schlägt das nicht durch - dh. es ist nur "irritierend" (für meine milde OCD... ;-). Das Problem hatte ich, zumindest in Citavi 5, ich glaube sogar noch früher, auch schon.

Kommentare (6)

Foto
1

Hallo Max

Können Sie rekonstruieren, wie die HTML-Tags in Ihr Projekt gelangt sind? Wenn Sie in Citavi auf der Titelkarte "Quelle der Titeldaten" einblenden, bekommen wir vielleicht heraus, wo das herkommt. Das sollte natürlich beim Import rausgeparst werden.

Freundliche Grüsse

Peter

Foto
1

Hallo Peter,

dass Tags importiert worden wären hätte ich noch nie erlebt. Das war immer nur über die manuelle Formatierung per Rechtsklick und Kontextmenü im Titelfeld. Und bei der erwähnten Kontrolle sowieso...kann bei nächster Gelegenheit ein Video machen.

Lg

Max

Foto
1

Ich habe einfache Versuche unternommen, das Problem nachzustellen; bisher ergebnislos. Ich stelle den Status dieses Postings aber noch nicht auf "Nicht reproduzierbar".

Freundliche Grüsse

Peter

Foto
Foto
1

Grundsätzlich gesehen habe ich das auch schon mal, aber wie von Max beschrieben ist so recht kein Muster ersichtlich, warum das manchmal bei manchen Titeln passiert. Beim nächsten Scrollen war schon wieder alles in Ordnung, meine ich mich zu entsinnen. Das ist eher irgendwas, was beim Rendern schief geht, so sieht es jedenfalls aus Nutzersicht aus.

Foto
1

Ich konnte die Ursache identifizieren!


Der Bug tritt nur auf, wenn nach einer Italic-Formatierung irgendwo im weiteren Titel ein Ampersand - & - vorkommt, das dann offenbar als ein Steuerungszeichen/Adressoperator für irgendwas interpretiert wird, und dazu führt, dass die <i></i> Tags (bzw. auch alle anderen Formatierungstags) nicht mehr gerendert werden - siehe Video. Allerdings hat das nur auswirkungen auf die Darstellung in der Titelliste, wäre mir aber bisher sonst nirgends untergekommen.

Foto
1

Hallo Max

Das ist ja ein Ding. Vielen Dank für die sehr gute Buganalyse. Der Bug wird mit nächster Beta gefixt.

Freundliche Grüsse

Peter

Foto
1

Das wird damit stark zusammenhängen: wenn man eine Kursivierung im Titel hat, wird alles, was Citavi als schließenden Tag interpretieren kann, gelöscht. Bspw. kann ein Titel das "Wort" "<\irony>" im Titel haben, aber wenn der Titel dann kursiv formatiert wird, wird das Wort gelöscht.

Foto
2

Wir haben Citavi Beta 6.2.6 veröffentlicht. Diese Version behebt das hier beschriebene Problem. Mehr Infos und Download unter http://www.citavi.com/beta