Mehrfachnachweisdarstellung nicht so [1, 2] sondern so [1][2]

Konrad G. hinzugefügt 7 Monaten her
gelöst

Hallo,

die Frage ist im Titel eigentlich schon formuliert. Ich habe mehrere Themen gefunden, die es anders herum wollen, aber so wie ich es will, dazu habe ich leider nichts gefunden. Als Zitierstil verwende ich Vancouver (German)

Kommentare (6)

Foto
1

Hallo Konrad,

vielen Dank für Ihre Frage.

Um ein Problem bei der Klammernsetzung in Mehrfachnachweisen zu beheben, bitte ich Sie, die aktuelle Beta-Version zu installieren, die wir unter http://www.citavi.com/beta bereitstellen. Falls Sie im Team an gemeinsamen Cloud-Projekt arbeiten, mögen bitte auch Ihre Kolleginnen bzw. Kollegen die Beta-Version installieren.

Wie beim Zusammenführen zweier Belege in einem Mehrfachnachweis mit den Klammern umgegangen wird, hängt von der Position der Klammern ab.

a) Sind die Klammern ein Teil der Komponente (ggf. einer kombinierten Komponente), werden diese auch bei einem Mehrfachnachweis als Teil des Belegs behandelt. Man erhält also die Form: Form "[Wiener 2006], [Maier 2013]" bzw. "[1], [2]" oder "[1, S. 5], [2, S. 11]".

b) Sind die Klammern nicht Teil der Komponente, sondern wurden diese außerhalb der Komponente in der Vorlage eingefügt, werden beim Mehrfachnachweis die Belege ohne die Klammern zusammengeführt. Das führt zu der Ausgabe: Form "[Wiener 2006, Maier 2013]" bzw. "[1; 2]" oder "[1, S. 5; 2, S. 11]".

Um nun wie unter a) beschrieben die Klammern in die Komponente zu integrieren, gehen Sie bitte folgendermaßen vor:

  1. Rufen Sie beim Unklaren Dokumententyp im Regelset Kurznachweis im Text die Komponente "Index im Literaturverzeichnis" mit einem Doppelklick auf.
  2. Ziehen Sie dann die übrigen benötigten Komponenten aus der Komponentenpalette auf der linken Seite an die gewünschte Position auf der Montage-Fläche, also in dem Fall noch "Zitat-Seiten", s. auch folgende Handbuch-Seite (steigen Sie direkten ab Schritt 2 ein, damit Sie die Einstellungen von der Index-Komponente gleich übernehmen). https://www1.citavi.com/sub/manual6/de/index.html?cse_combining_elements_in_one_component.html
  3. Weil die einzelnen Elemente innerhalb einer kombinierten Komponente nicht über eigene Interpunktionsfelder verfügen, fügen Sie zwischen "Index im Literaturverzeichnis" und "Zitat-Seiten" noch ein Textelement hinzu und tragen dort ", " (inkl. des nachfolgenden Leerzeichens) ein.
  4. Als Eigenschaft für das Textelement wählen Sie bitte "Nur anwenden: "wenn das vorhergehende und das nachfolgende Element Daten enthält". Auf diese Weise wird es nur im gewünschten Fall angezeigt.
  5. Fügen Sie nun auch für die eckigen Klammern jeweils ein Textelement hinzu. Als Eigenschaft für diese Textelemente wählen Sie bitte Nur anwenden: "wenn ein Element in dieser Komponente Daten enthält".
  6. Klicken Sie auf die weiße Montagefläche und korrigieren Sie im Feld Beschriftung den Eintrag, indem Sie die Klammern, die Interpunktion sowie den Platzhalter {1} für das zweite Element ergänzen.f5efe5f45d4b475e9ec4880c90b01e52
  7. Bestätigen Sie die Bearbeitung der kombinierten Komponente mit "OK".
  8. Markieren Sie nun in der Standard-Vorlage die überflüssigen Komponenten (also die nunmehr doppelten Klammern sowie "Zitat-Seiten") und drücken Entf.
    f8c79a0facc709d8587025888a1ea5f4
  9. Speichern Sie die Änderungen am Zitationsstil ab.

Bitte denken Sie daran, den angepassten Stil auch in Citavis Word Add-in auf der Registerkarte Citavi auszuwählen. Klicken Sie auf den Auswahlpfeil hinter Zitationsstil und wählen Sie den Stil aus der Dropdown-Liste aus, s. Screenshot.

Viele Grüße

Susanne

Foto
1

Hallo Susanne,

danke für die schnelle Antwort. Da ich meine Arbeit auf meinem Arbeitslaptop schreibe, muss ich noch warte, bis ich Adminrechte bekomme um die Beta installieren zu können. Ich wollte dann schonmal von Zuhause weiterarbeiten, aber mir ist aufgefallen, dass dort nicht der Zitierstil synchronisiert wurde, den ich auf meinem Arbeitslaptop ausgewählt und modifiziert habe. Wird dieser nicht synchronisiert?

Freundliche Grüße

Konrad Günther

Foto
1

Hallo Susanne,

habe es hinbekommen. Habe auch herausgefunden, dass das mit der Synchronisierung nicht funktionert. Habe es manuell in den richtigen Ordner eingefügt. Eine Frage jetzt noch: Wie bekomme ich das Komma zwischen [1], [2] entfernt? Ich habe bei Datei - Eigenschaften des Zitierstils - Mehrfachnachweise - Haupt-Indexnummern trennen mit - einfach ein Leerzeichen eingefügt, hatte damit aber komischerweise keinen Erfolg. Haben Sie dafür eine Lösung?

Freundliche Grüße

Konrad

Foto
1

Hallo Konrad,

vielen Dank für Ihre Rückmeldung.

Leider ist es tatsächlich aus Sicherheitsgründen nicht möglich, eigene Zitationsstile über die Cloud zu synchronisieren, da diese Skripte enthalten können. Sie müssten den angepassten Zitationsstil auch auf dem zweiten Rechner in das Verzeichnis Dokumente\Citavi 6\Custom Citation Styles kopieren. Der Stil muss zudem nach jeder Änderung erneut auf den anderen Rechner kopiert werden.

In Bezug auf das Komma senden Sie mir bitte ein Beispiel-Dokument (max. 3 Seiten).

Sie würden dazu eine neue Word-Datei mit Ihrem Citavi-Projekt verknüpfen, Ihren Zitationsstil auswählen und über das Word Add-In diejenigen Titel in das Word-Dokument einfügen, bei denen Sie Probleme beobachtet haben. Diese Referenzen stehen dann für den IST-Zustand, mit dem Sie noch nicht zufrieden sind. In das Word-Dokument ergänzen Sie bitte von Hand den SOLL-Zustand.

Da Sie einen selbst angepassten Stil nutzen, senden Sie uns den Stil auch zu. Sie finden die Datei im Ordner Documents\Citavi 6\Custom Citation Styles.

Die Datei(en) senden Sie bitte über unser Upload-Formular http://www.citavi.com/transfer. Bitte verwenden Sie dieselbe Mail-Adresse wie für die ursprüngliche Anfrage an uns und geben Sie dort im Fenster "Nachricht" diese Bearbeitungsnummer ein: #117290.

Viele Grüße

Susanne

Foto
1

Hallo Susanne,

ich habe die Dateien hochgeladen.

Freundliche Grüße

Konrad

Foto
1

Hallo Konrad,

vielen Dank für die Dateien.

Tatsächlich verhindert anscheinend die kombinierte Komponente aus "Index im Literaturverzeichnis" und "Zitat-Seiten" die Berücksichtigung des Trennzeichens im Mehrfachnachweis. Ich habe daher ein Bug-Ticket für unseren Entwickler erfasst.

Bis zur Fehlerbehebung müsste eine Ersetzungsregel als Workaround genutzt werden:

  1. Klicken Sie im Zitationsstil-Editor unter Datei > Eigenschaften des Zitationsstils > Ersetzungen auf Weitere und dann auf Hinzufügen.
  2. Tragen Sie folgende Ersetzungsregel ein:
    Suchen nach: ], [
    Ersetzen durch: ] [
  3. Speichern Sie die Änderungen in Ihrem Zitationsstil ab.

(Eine Alternative wäre ansonsten noch, auf die Ausgabe der zitierten Seiten zu verzichten.)

In Ihrem Stil habe ich den Workaround bereits eingebaut.

Viele Grüße

Susanne

Foto
1

Danke. Hat geklappt. Seitenzahlen benötige ich sowieso nicht.

Leider habe ich ein weiteres Problem. Ich zitiere 3 verschiedene Quellen. Zuerst [1] [2] zusammen hinter einem Absatz, dann [1] [3] hinter einem Absatz. Wenn ich dann aber unter einer Abbildung wieder [3] setze, dann wird dieses auf einmal zu [1] und die ganze Reihenfolge ist im Eimer. Ich habe unter Eigenschaften des Zitationsstils unter LIteraturverzeichnis "Reihenfolge der Zitierung gewählt", bei Mehrfach-Nachweisen ebenso.

Foto
1

Hallo Konrad,

vielen Dank für Ihre Rückmeldung.

Wenn Sie Quellenangaben in einen Positionsrahmen von Word einfügen, kann Citavis Word Add-In die Reihenfolge der Referenzen im Textfluss nicht mehr korrekt ermitteln. Während das bei Autor-Jahr-Stilen (Müller 2011b) unproblematisch ist, ist das bei Stilen, die Referenznummern in der Reihenfolge der Zitierung einfügen, eine Fehlerquelle. Wir haben die Schwierigkeit im Handbuch beschrieben und bieten dort eine Lösungsmöglichkeit an: http://www.citavi.com/sub/manual6/de/index.html?dont_insert_references_in_frames.html

Dieses Video zeigt, wie Sie die Positionsrahmen auflösen und stattdessen die Grafiken mit der Textfluss-Option in Word positionieren: http://www.screencast.com/t/6cFsfeFxNRhz

In einem Forenbeitrag haben wir die verschiedenen Möglichkeiten zur Positionierung von Abbildungsbeschriftungen kommentiert:

https://help.citavi.com/topic/quellennachweis-in-textfeldbildbeschriftung-an-einigen-stellen-nicht-mgl-word#comment-91238

Viele Grüße

Susanne

Foto
Foto
1

Hallo Konrad,

wir konnten die Fehlerursache mittlerweile finden und beheben. Noch haben wir allerdings keine neue Beta-Version (6.4.x) veröffentlicht, welche die Fehlerkorrektur enthält.

Ich möchte Sie darum bitten, den Nachrichten-Bereich rechts im Startfenster von Citavi im Auge zu behalten. Wir kündigen dort die Veröffentlichung der nächsten Beta-Version an.

Viele Grüße

Susanne

Foto
1

Hallo, ich würde Mehrfachnachweise gerne als [1,2] oder [1-3] oder [1,3,5-8] darstellen.

Also genau anders herum als Konrad und wie es unter der ersten Antwort unter b) beschrieben ist. Ich finde den Weg dorthin allerdings nicht.

Ich nutze die Zitierweise PLoS Medicine, habe sie allerdings personalisiert. Auf meinem alten Rechner hatte ich eine ältere Version von Word und auch von Citavi, damals hat alles genau gepasst. Auf meinem neuen Laptop mit neuster Citavi- und Word-Version erscheinen meine Mehrfachnachweise zwar noch als solche, also werden mir weiter als Mehrfachnachweise angezeigt, allerdings sind alle Quellen einzeln durch eckige Klammern getrennt [1],[2]. Meinen Zitationsstil habe ich in die Custom Citation Styles kopiert und alles andere ist auch wie zuvor.

Vielen herzlichen Dank schonmal! Judith

Foto
1

Guten Tag Judith

Um das genannte Ziel zu erreichen, müssen die eckigen Klammern als Textelemente um die Komponente "Index im Literaturverzeichnis" gesetzt werden:

/c4f95767bd32d9ad682216529d9a4a1c

Im beigefügten Stil (nur Citavi 6) habe ich das für Sie gemacht. Bitte kopieren Sie die beigefügte Datei in das Verzeichnis Dokumente\Citavi 6\Custom Citation Styles.


Im Word Add-In wählen Sie den Stil auf der Registerkarte "Citavi" aus. Klicken Sie auf den Auswahlpfeil hinter "Zitationsstil" und wählen Sie dort Ihren Stil aus.

Freundliche Grüsse

Peter

Foto
1

Hallo Peter, vielen Dank für die schnelle Hilfe. Leider hat es nicht funktioniert. Die Zitierweise ist weiterhin [1], [2] oder [1]-[3].

Ich würde aber sehr gerne in der Form [1,2] und [1-3] zitieren. Könnte ich etwas falsch gemacht haben oder gab es vielleicht ein Missverständnis?

Foto
1

Hallo Judith,

vielen Dank für Ihre Rückfrage.

Da gab es tatsächlich leider ein Missverständnis.

Wenn Sie die von Ihnen gemachten Anpassungen nicht mehr benötigen, können Sie wieder zum Original-Stil "PLOS Medicine (As of 2015)" wechseln.

Falls Sie bei Ihrem eigenen Stil bleiben möchten:

Wie beim Zusammenführen zweier Belege in einem Mehrfachnachweis mit den Klammern umgegangen wird, hängt wie gesagt von der Position der Klammern ab.

a) Sind die Klammern ein Teil der Komponente (ggf. einer kombinierten Komponente), werden diese auch bei einem Mehrfachnachweis als Teil des Belegs behandelt. Man erhält also die Form: Form "[Wiener 2006], [Maier 2013]" bzw. "[1], [2]" oder "[1, S. 5], [2, S. 11]".

b) Sind die Klammern nicht Teil der Komponente, sondern wurden diese außerhalb der Komponente in der Vorlage eingefügt, werden beim Mehrfachnachweis die Belege ohne die Klammern zusammengeführt. Das führt zu der Ausgabe: Form "[Wiener 2006, Maier 2013]" bzw. "[1; 2]" oder "[1, S. 5; 2, S. 11]".

Um nun wie unter b) beschrieben die Klammern aus der Komponente zu entfernen und in die Vorlage zu integrieren, gehen Sie bitte folgendermaßen vor:

  1. Rufen Sie beim Unklaren Dokumententyp im Regelset Kurznachweis im Text die Komponente "[Index im Literaturverzeichnis]" mit einem Doppelklick auf.
  2. Markieren Sie die überflüssigen Elemente (also die Klammern sowie ggf. auch das Element "Zitat-Seiten") und drücken Entf.
  3. Falls auf der weißen Montagefläche keine Klammern vorhanden sind, klicken Sie auf das Element "Index im Literaturverzeichnis" und überprüfen die Felder "Text davor" sowie "Text danach".
  4. Klicken Sie auf die weiße Montagefläche und korrigieren Sie im Feld Beschriftung den Eintrag, indem Sie die Klammern entfernen.
  5. Bestätigen Sie die Bearbeitung der Komponente mit "OK".
  6. Ziehen Sie dann die übrigen benötigten Komponenten aus der Komponentenpalette auf der linken Seite an die gewünschte Position in die Standardvorlage im Regelset Kurznachweis im Text, also in dem Fall noch die beiden eckigen Klammern sowie ggf. "Zitat-Seiten".
    c70053c6dd1833e3cefaf40be00a0b5e
  7. Falls es in der linken Spalte noch keine eckigen Klammern geben sollte, erstellen Sie jeweils eine neue Komponente mit einem Textelement und ziehen Sie diese anschließend in die Standardvorlage:
    https://www1.citavi.com/sub/manual6/de/index.html?cse_creating_new_components.html
    https://www1.citavi.com/sub/manual6/de/index.html?cse_text_elements.html
  8. Speichern Sie die Änderungen am Zitationsstil ab.

Bitte denken Sie daran, den angepassten Stil auch in Citavis Word Add-in auf der Registerkarte Citavi auszuwählen. Klicken Sie auf den Auswahlpfeil hinter Zitationsstil und wählen Sie den Stil aus der Dropdown-Liste aus, s. Screenshot.

Viele Grüße

Susanne

Foto
1

Hallo Susanne, vielen Dank für die schnelle Hilfe!

Leider habe ich es trotz der detaillierten Beschreibung nicht geschafft - am Ende wurde meine Zitierweise als 1],2] angegeben, also auch gar nicht was ich wollte. Die Ursache konnte ich nicht finden.

Der Tipp, dass meine alte Zitierweise nun unter PLOS Medicine (As of 2015) zu finden ist, hat mir allerdings sehr geholfen! Ich habe meine eigenen Modifikationen (Übersetzungen wie "accessed" oder "references" auf Deutsch) in PLOS Medicine (As of 2015) übernommen - das ging deutlich schneller und unkomplizierter.

Herzlichen Dank noch einmal für die schnelle Antwort!

Judith

Foto
1

Hallo Judith,

vielen Dank für Ihre Rückmeldung.

Ich freue mich, dass Sie mit der Anpassung des Original-Stils nun bereits eine Lösung gefunden haben.

(Ich vermute, dass beim ursprünglichen, älteren Zitationsstil versehentlich die Klammern nicht korrekt gesetzt wurden oder aber eine Ersetzungsregel dazwischenfunkt - falls gewünscht, kann ich den Stil überprüfen.)

Viele Grüße

Susanne

Foto
1

Vielen Dank Susanne! Wenn ich erneut auf ein Problem stoßen sollte komme ich gerne auf das Angebot zurück!

Foto
1

Hallo Judith,

gern geschehen und vielen Dank für Ihre freundliche Rückmeldung.

Viele Grüße

Susanne

Foto