Latex / Biber Kompilerfehler

Marius P. hinzugefügt 2 Jahren her
beantwortet

% !TeX TXS-program:bibliography = txs:///biber
\documentclass{scrbook}
%\usepackage[utf8]{inputenc}
%\usepackage[T1]{fontenc}

%\usepackage[english]{babel} % works as expected
\usepackage[ngerman,english]{babel} % compilation fails
%\usepackage[ngerman]{babel} % compilation fails

\usepackage{csquotes}
\usepackage{filecontents}
\begin{filecontents}{b.bib}
% This file was created with Citavi 6.0.0.2

@article{Muster,
 author = {Muster, Max},
 title = {{The Project {\textquotedbl}Projectname{\textquotedbl} is nice}}
}


\end{filecontents}
\usepackage[style=ieee]{biblatex}
\addbibresource{b.bib}

\begin{document}
\cite{Muster}
\printbibliography
\end{document}\end{document}Nach dem Update auf Citavi 6 funktioniert das übersetzen meines TeX Dokuments mit exportierter Bibliography nicht mehr. Ich nutze Latex mit Biber und konnte das ganze auf ein Minimaldokument reduzieren.

Es scheint daran zu liegen, dass anstelle von "\dq" jetzt "\textquotedbl" verwendet wird. Sobald ich in dem Dokument die Option "ngerman" verwende kompiliert das Dokument nicht mehr.

Gibt es eine Option das frühere Verhalten wiederherzustellen?

Kommentare (5)

Foto
1

Hallo Sebastian,

danke für den schnellen Hinweis. Auf die Idee, dass es an biblatex-ieee liegt bin ich gestern Abend nicht mehr gekommen. Ich habe einen Issue im Repository von biblatex-ieee eröffnet (https://github.com/josephwright/biblatex-ieee/issues/41) und hoffe dort mehr zu erfahren.

Falls jemand anderes über das Problem stolplern sollte: Zumindest für größtenteils englische Dokumente kann man die Option shorthands=off von babel nutzen um die Konvertierung der Umlaute abzuschalten. So lässt sich das Dokument wenigstens wieder kompilieren.

Danke und viele Grüße

Marius

Foto
1

Hallo Sebastian,

hier noch ein Feedback.

Ich bin unabhängig von Marius auf das gleiche Problem (ich benutze authoryear-comp) gestoßen und habe ebenso "\textquotedbl" als Übeltäter ausmachen können. "\dq" hat bei mir immer bestens funktioniert, die neue Variante leider gar nicht. Das bedeutet, dass ich es sowohl in meinem Arbeitsdokument als auch im obenstehenden MWE mit authoryear/authoryear-comp/ieee nicht zum Laufen bekomme. Numeric scheint nur auf Anhieb zu funktionieren, da es die {\textquotedbl} dann doch nicht wiedergibt.

Erfreulich hingegen ist, dass alle andere Anführungszeichen, die Citavi über das Kontextmenü Sonderzeichen vorschlägt, auch funktionieren. Das Umschreiben der betroffenen Einträge in Citavi wird zwar in der Suche dauern, ist aber akzeptabel.

Viele Grüße

Sebastian

Foto
1

Hallo Sebastian,

ich habe inzwischen herausgefunden, dass es auch die option \shorthandoff{"} des Babel Pakets gibt. Mein modifiziertes MWE lässt sich dann auch kompilieren. Das ist ggf. einfacher als alle Referenzen zu ändern.

Viele Grüße

Marius


\documentclass{scrbook}
%\usepackage[utf8]{inputenc}
%\usepackage[T1]{fontenc}

%\usepackage[english]{babel} % works as expected with ieee and default style
\usepackage[ngerman,english]{babel} % compilation fails with ieee style
%\usepackage[ngerman]{babel} % compilation fails with ieee style

\usepackage{csquotes}
\usepackage{filecontents}
\begin{filecontents}{b.bib}
% This file was created with Citavi 6.0.0.2

@article{Muster,
 author = {Muster, Max},
 title = {{The Project {\textquotedbl}Projectname{\textquotedbl} is nice}}
}


\end{filecontents}
\usepackage[style=ieee]{biblatex} % fails with "Argument of " has an extra }" if babel includes option ngerman
%\usepackage{biblatex} % works with all options of babel
\addbibresource{b.bib}

\begin{document}
\cite{Muster}
\shorthandoff{"} % turn off shorthands; compilation works in all cases
\printbibliography
\shorthandon{"} % restore shorthands to normal
\end{document}

Foto
1

Lieber Marius,

besten Dank für den Hinweis, das werde ich mal ausprobieren!


Viele Grüße

Sebastian

Foto
1

Hallo zusammen,

auch ich kann den Fehler mit authoryear und authoryear-comp nicht reproduzieren, wenn ngerman und english bei babel aktiviert sind. Nur mit ngerman funktionieren authoryear und authoryear-comp nicht. Numeric klappt dann z.B. auch nicht.

viele Grüße

Andreas