Export nach Bibtex mit é

Mathias A. hinzugefügt 15 Monaten her
beantwortet

Hallo,

ich wollte gerade einen Bibtex export aus Citavi 6 in Latex verwenden. Problem ist, bei den Autoren ist ein "Andé" dabei. Beim Export habe ich die Option "Latex Notation verwenden" aktiviert. Leider wird "André" exportiert statt "Andr\'e". Gibt es dafür einen Workaround außer die Bibtexdatei manuell zu ändern?

Beste Antwort
Foto

Also kurz zur Zusammenfassung:

Es ist ein Problem in der Codierung gewesen. Der Export muss mit Westeuropäisch (ISO) stattfinden Siehe vorletzter Kommentar auf die Frage von Sebastian. Danke für den Support.

Kommentare (4)

Foto
1

Hallo Mathias

Um das Problem zu beheben, bitte ich Sie, die aktuelle Beta-Version (6.3.1) zu installieren, die wir unter http://www.citavi.com/beta bereitstellen.

Freundliche Grüsse

Peter

Foto
1

Guten Tag Peter,

ich muss mich ein wenig korrigieren. Nicht der Autor ist das Problem, sondern eine URL, in der dieser Name vorkommt. In der URL wird das é nicht durch \'e ersetzt.

Foto
1

Hallo Mathias

Ich kann das Problem noch nicht reproduzieren:

% This file was created with Citavi 6.3.1.0

@incollection{Höhn:1972,
 author = {Höhn, E.},
 title = {Geschichte der Entwicklungspsychologie und ihre wesentlichen Ansätze},
 url = {http://www.test.de/andré;},
 pages = {21--45},
 publisher = {{Verlag für Psychologie Hogrefe}},
 editor = {Thomae, Hans},
 booktitle = {Handbuch der Psychologie},
 year = {1972},
 address = {Göttingen}
}
Freundliche Grüsse

Peter

Foto
1

Beim mir ist noch eine kleine Abweichung: Die Internetadresse habe ich auf das Tag howpublished anstatt URL gelegt. Wenn ich diese Datei dann versuche in Latex zu verwenden wird das "é" als error markiert. Ich habe per Hand das é in der URL zu \'e geändert.

Foto
1

Evt. prüft (ich weiss es wirklich nicht, darum nur Vermutung) Ihr Editor auf ungültige URLs und hat dabei noch nicht berücksichtigt, dass aktuell auch Akzente verwendet werden dürfen?

Foto
1

Aber ob das eine gültige URL ist oder nicht ist doch eigentlich irrelevant. Wenn ich in Latex – aus welchen legitimen Gründen auch immer – die Kodierung nicht wechseln kann, etwa per \usepackage[utf8]{inputenc}, dann muss ich mich doch darauf verlassen können, dass Citavi Sonderzeichen korrekt mit Steuerzeichen umwandelt.

Foto
1

Hallo Peter,

nein am Editor (Lyx) liegt es nicht. Die Literaturdatenbank, namentlich die bibtex-Datei, wird von Bibtex verarbeitet. Bibtex an sich erlaubt keine Sonderzeichen wie "é", sondern erwartet die Latexschreibweise und das in allen Feldern. Interessanterweise wird die Ersetzung von "é" beim Autorenfeld durch Citavi korrekt gemacht.

Im Endeffekt steht die Frage im Raum ob es ein Bug ist oder ob es so designed ist? Falls es so designed ist, wäre eine zusätzliche Option diese Sonderzeichen auch in URL's zu ersetzen wünschenswert, da sonst nicht mit bibtex gearbeitet werden kann.

Foto
1

Hallo, Mathias

Das ist "by design". BibTeX (das Format, nicht das Programm) ist eigentlich agnostisch was die Zeichenkodierung angeht. Citavi exportiert die URLs aus den entsprechenden Feldern verbatim, um bei der mittlerweile praktisch standardmäßigen Verwendung von Paketen wie hyperref die Klickbarkeit von URLs zu gewährleisten.

Ein grundsätzliches Problem gibt es hier aber auch dann nicht, wenn Sie nicht hyperref oder ähnliches verwenden.

Unter der Annahme, dass folgende bib-Datei aus Citavi (mit der Textkodierung UTF8) exportiert wurde, läuft das nachfolgende Beispiel problemlos durch, vorausgesetzt Sie verwenden bibtex8 (was, wenn die Verwendung von biblatex nicht möglich ist, auch aus anderen Gründen immer eine gute Idee ist):

bib-Datei (andre.bib):


@misc{Meyer.1994,
 author = {Meyer, Andr{\'e}},
 title = {Ein~Titel},
 howpublished = {https://www.andrés-blog.de},
 year = {1994}
}
Minimalbeispiel:


\documentclass{article} 
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\begin{document}
Dies ist ein Text. Hier wird \cite{Meyer.1994} zitiert.
\bibliography{andre}
\end{document}
Ergebnis des LaTeX-Laufs mit bibtex8:

/a9702ef2ab133015211828a687331645

Viele Grüße

Sebastian

Foto
1

Hallo Sebastian,

danke für die Aussage, dass es so designed ist. Ich habe die Prozessierung mit Bibtex 8 probiert. Auch da habe ich einen Fehler. Angehängt sind das Exportergebnis und der Fehler aus pdflatex (Lyx) bzw. bibtex8. Vielleicht finden wir damit eine Lösung.


Gruß

Mathias

Foto
1

Hallo, Mathias,

da scheint (aus welchen Gründen auch immer) die Zeichenkodierung kaputtzugehen: l.34 ...ge-extension-ready-review-andrĂ©-borrmann}

Diese Zeichensequenz entsteht, wenn UTF8 als ANSI (also "latin1") dargestellt wird. Was passiert denn, wenn Sie die bib-Datei in Citavi mit "Westeuropäisch (ISO)" als Zeichensatz exportieren?

/6875d0ef88eddd96956ce6ac8e57b7ad

Viele Grüße

Sebastian

Foto
1

Das hat nun funktioniert. Auch wenn der Link beim anklicken eine falsche Website öffnet, so ist wenigstens der Text korrekt.


Danke!

Foto
Foto
1

Also kurz zur Zusammenfassung:

Es ist ein Problem in der Codierung gewesen. Der Export muss mit Westeuropäisch (ISO) stattfinden Siehe vorletzter Kommentar auf die Frage von Sebastian. Danke für den Support.