Citavi 5 Publikationsassistent für Texmaker - wie Element einfügen ohne Prefix ("S.")

timon a. hinzugefügt 9 Monaten her
beantwortet

Hallo zusammen,

ich nutze Citavi 5, da Citavi 6 ja nicht mehr den Publikationsassistenten anbietet bzw. ohne der Funktion "Nur Titelplatzhalter", die essenziell für die Arbeit mit Texmaker ist.

Nur fügt der Publikationsassistent die Seitenangabe immer mit dem Prefix S. ein, was für mich stören und nicht gewollt.

Da ich aber keine Möglichkeit finde, dies abzustellen, würde ich mich über Hinweise sehr freuen! :)

Lieben Dank!

Kommentare (3)

Foto
1

Guten Tag Timon

Unter Citavi 6 können Sie weiterhin BibTeX-Keys mit Hilfe des LaTeX-Assistenten in eine TeX-Datei einfügen, die Sie mit Texmaker erstellen (s.a. Handbuch):

/6bd105ffb62de9fb4769eff7d6317991

Können Sie bitte einen Screenshot senden, der zeigt, wie Sie unter Citavi 5 mit dem Publikationsassistenten einen Quellennachweis in Ihr Dokument einfügen? (Aus Datenschutzgründen mögen Sie ggf. den Screenshot nicht im Forum posten, sondern an service@citavi.com senden; bitte geben Sie dann die Ticket-ID 102688 an.)

Freundliche Grüsse

Peter

Foto
1

Hallo Peter,

lieben Dank für Deine so zeitnahe Reaktion!

Citavi 6 hilft mir an der Stelle nicht weiter, da die Funktion "Nur Titelplatzhalter" nicht zur Verfügung steht - siehe Forenbeitrag und ich nicht Inhalte von Wissenselementen in Texmaker einfügen will, sondern nur deren Seitenangabe und deren Titel. In Word war dies ja über Rechtsklick -> Nur Nachweis (oder ähnlich) möglich.


Und eben die Titelplatzhalter-Funktion steht in Citavi 5 zur Verfügung, fügt aber auch jedes Mal ein S.~ als Prefix ein, was ich nicht haben möchte und bis jetzt nicht herausfinden konnte, wie ich das abstelle.


Bild 1 zeigt hierfür die entsprechende Option im Publikationsassisten in Citavi 5.


Und in Bild 2 sieht man, dass durch ein Doppelklick auf ein Wissenselement der Titelplatzhalter eingefügt wird, aber eben mit dem Prefix, der ungewollt ist.


Ich würde mich freuen, wenn Sie mir dort weiterhelfen könnten :)

Foto
Foto
1

Hallo Timon

Das Präfix ist in diesem Fall hartcodiert. Es gibt leider keine Option, das innerhalb des Programms zu ändern.

Freundliche Grüsse

Peter

Foto
1

Guten Tag,

ich brüte gerade über derselben Symptomatik. Was heißt denn "in diesem Fall hartcodiert"? Gibt es also auch Fälle, in denen das nicht der Fall ist und wenn ja, wovon hängt das ab?


Für die Hilfe schon jetzt besten Dank!

Foto
1

Hallo, Mathias

In diesem Fall heißt es im Zusammenhang mit den LaTeX-Zitierkommandos. Im Fall des Word Add-Ins ist es anders.

Viele Grüße

Sebastian

Foto
1

Hallo Sebastian,

vielen Dank für die schnelle Antwort!

Gibt es denn (noch) Bestrebungen, das für LaTeX-Zitierkommandos zu ändern?

Oder ist u.U. bekannt, ob es LaTeX-Befehle gibt, die das Drucken von "S." unterdrücken (wohlwissend, dass das eine LaTeX-spezifische Frage ist. Angesichts der Themenverwandtheit sind ja aber vielleicht Lösungen über LaTeX auch hier bekannt).

Vielen Dank für die Hilfe!

Foto
1

Hallo Mathias

Wir möchten uns den BibTeX-Export für Citavi 7 insgesamt nochmal ansehen. Ich werde diesen Punkt mit auf unsere Liste setzen. Soweit ich das einschätzen kann, gibt es ohnehin einen deutlichen Trend in Richtung biblatex mit seinen flexibleren Zitierkommandos, so dass hier ohnehin Handlungsbedarf besteht.

Ob BibTeX "S." im Nachweis mit ausgibt, hängt vom ausgewählten Bibliographiestil ab, bzw. davon, was Sie im optionalen Parameter [...] von \cite übergeben haben

Viele Grüße

Sebastian

Foto
2

Hallo Sebastian,

soweit ist mir schon gut geholfen - an dieser Stelle also schonmal und nochmal vielen Dank! Ich werde das Präfix "S." (wo nötig) von Hand entfernen, was angesichts der im Übrigen weitgehenden Automatisierung tragbar ist. Da das Thema aber auch auf der ToDo-Liste steht, hier nochmal etwas genauer zur Problematik bei mir. Vielleicht hilft das bei der Umsetzung weiter. Das angehängte Bild zeigt die über den Publikationsassistenten eingefügten Zitate. Was LaTeX anhand der (auch modifizierten) .cbx Dateien aus den BibTexKeys macht, habe ich soweit eingestellt. Misslungen ist mir bislang aber ein Unterdrücken des (von Citavi als solches explizit bei der konkreten Fundstelle eingefügten) Präfixes. Könnte man den Publikationsassistenten derart konfigurieren, dass statt \cite[S.~xy]{BibTexKey} das Kommando \cite[xy]{BibTexKey} im LaTeX-Editor eingefügt wird, wäre das Problem jedoch behoben. Dies nehme ich nun von Hand vor, wodurch der erwünschte Effekt erzielt wird.

Das aber wie gesagt nur als Input von Nutzerseite.

Viele Grüße

Mathias

Foto