BibLaTex - URLs erhalten den Vorspann \url

Henning V. hinzugefügt 9 Monaten her
kein Problem

In meiner DB befindet sich der Eintrag mit dem BibTexKey Haynes.2017 der in der, mit der Exportfunktion erzeugten BibLaTex-.bib-Datei so aussieht:

@collection{Haynes.2017,
 year = {2017},
 title = {CRC handbook of chemistry and physics},
 url = {\url{http://site.F.com/lib/tubraunschweig/docDetail.action?docID=11276940}},
 keywords = {Chemie;Datensammlung;Physik;Tabelle},
 edition = {97th edition},
 publisher = {{CRC Press}},
 isbn = {9781498754286},
 editor = {Haynes, William M.},
 abstract = {},
 pagetotal = {12643},
 usera = {Datei zuordnen},
 note = {Haynes, William M. (Herausgeber)},
 language = {eng},
 subtitle = {A ready-reference book of chemical and physical data},
 location = {Boca Raton and London and New York},
 file = {https://ebookcentral.proquest.com/lib/gbv/detail.action?docID=4711508}
}

nach dem Biber- und PDFLaTex-Lauf erhalte ich das Ergebnis:

W. M. Haynes, Hrsg. CRC handbook of chemistry and physics. A ready-reference book

of chemical and physical data. eng. 97th edition. Haynes, William M. (Herausgeber).

Boca Raton, London und New York: CRC Press, 2017. 12643 S. url:7 %5Curl%Bhttp:

//site.ebrary.com/lib/tubraunschweig/docDetail.action?docID=11276940%

7D.

Wiso erscheint das "%5Curl%B" ?


Mir ist klar, dass es die Kodierten Zeichen aus dem Eintrag in der Option url sind.

Aber sollten diese nicht von einem der beteiligten Tools ausgefiltert werden ?

Oder brauche ich ein weiteres Paket oder eine Option in LaTeX, damit das sauber funktioniert?

Ähnlich verhält es sich auch bei DOI-Einträgen. Vgl. folgendes Bespiel, dass beides enthält:

@article{Alzetta.1979,
 author = {Alzetta, G. and Moi, L. and Orriols, G.},
 year = {1979},
 title = {Nonabsorption hyperfine resonances in a sodium vapour irradiated by a multimode dye-laser},
 url = {\url{https://doi.org/10.1007/BF02739035}},
 pages = {209--218},
 pagination = {page},
 volume = {52},
 issn = {1826-9877},
 journaltitle = {Il Nuovo Cimento B (1971-1996)},
 doi = {\url{10.1007/BF02739035}},
 number = {2},
 abstract = {The fluorescence intensity of a sodium vapour excited by a multimode dye-laser is observed as a function of the applied magnetic field: a resonant decrease of the fluorescence occurs when the frequency difference between two laser modes coincides with the frequency of an hyperfine transition of the ground state. An experimental proof is reported which evidences the coherent nature of the phenomenon.},
 pagetotal = {10},
}
ergibt:


G. Alzetta u.a. „An experimental method for the observation of r.f. transitions and

laser beat resonances in oriented Na vapour“. In: Il Nuovo Cimento B (1971-1996)

36.1 (1976), S. 5–20. doi: \url{10.1007/BF02749417}. url: %5Curl%7Bhttps:

//doi.org/10.1007/BF02749417%7D.


Ich habe in den Exportdefinitionen die Option URL-Package gefunden.

Bei der verendeten, mitgelieferten Exportdefinition BibLateX scheint diese nicht aktiviert zu sein.

Was diese Option bewirkt, konnte ich leider noch nicht in der Dokumentation finden.

Im Letzten Fenster des Export Dialogs ist nochmals eine Option "URL-Package verwenden". Hier steht in der Seitenhilfe ausreichend Information.

Sind die beiden Optionen identisch?

Die Exportvorlage habe ich gespeichert, auch, um die gemachten Einstellungen für einen Fall wie diesen nachvollziehen zu können. Allerdings kann ich keine Möglichkeit finden die Details der Vorlage anzuschauen oder zu bearbeiten.

Wo werden die Export-Vorlagen gespeichert? Die Export-Definitionen habe ich im Ordner unter AppData\local...\Mappings gefunden.

Kommentare (2)

Foto
2

Hallo, Henning,

haben Sie die Option url-Package verwenden in Citavi angeschaltet? Wenn ja, schalten Sie diese bitte aus, sie wird nur für einige BibTeX-Pakete benötigt. Auch die anderen beiden Häkchen in diesem Dialog sollten nicht gesetzt sein, biber/biblatex kümmern sich auch um Sonderzeichen und Großbuchstaben.

Viele Grüße

Sebastian

Foto
1

Hallo Sebastian,

ich habe ganz vergessen Danke zu sagen. Die Einstellungsänderung hat es gelöst.

Viele Grüße

Henning