DOI mit Unterstrich wird als \textunderscore in Latex angezeigt

Maria M. hinzugefügt 30 Tagen her
gelöst

Guten Tag,

ich schreibe meine Abschlussarbeit in Texstudio, das Literaturverzeichnis mache ich mit Biblatex und Biber. Eine Quelle hat eine DOI mit einem Unterstrich (10.1007/978-3-662-48986-4_1995). Wenn ich sie einfach so in Citavi eintrage, habe ich das Problem, dass im Literaturverzeichnis dann 10.1007/978-3-662-48986-4{\textunderscore}1995 steht.

Ich habe bereits mehrere Varianten versucht um das Problem zu beheben, aber leider war ich noch nicht erfolgreich.


Danke im Voraus für die Unterstützung.

Maria

Kommentare (3)

Foto
3

Hi,

ich hab das Problem auch gerade, und hier gab es dazu auch schonmal nicht wirklich eine Lösung: https://help.citavi.com/topic/unterstrich-in-dois-ersetzen-lassen Allerdings ist es zumindest ein Workaround, neben der Möglichkeit, für die finale Version alle {\textunderscore } in der bib-Datei durch _ zu ersetzen.

Was bei mir auch nicht funktioniert hat, ist, die Option "LaTeX-Notation verwenden" beim Export zu deaktivieren. Das wirkt sich zwar auf ß und äs aus, aber nicht auf die Unterstriche in den DOIs...

Danke auch von mir schonmal für eine Lösung...

Philip

Foto
3

Hallo Maria & Philip,

vielen Dank für Ihre Beiträge.

Ich konnte das Problem reproduzieren und habe unseren Entwickler informiert.

Viele Grüße

Susanne

Foto
1

Hallo Maria & Philip,

tatsächlich muss das BibLaTeX-Paket verwendet werden:

  • Menü Datei > Exportieren > Exportieren > Den markierten Titel bzw. gewünschte Option anklicken > BibTeX > BibTeX-Exportdefinition bearbeiten > Weiter bis zur letzten Seite > BibLaTeX Package verwenden.

70e51f0a45a7677558112c2a491671dc

Alternativ kann man auch gleich biblatex/biber und in Citavi den BibLaTeX-Export nutzen.

Viele Grüße

Susanne

Antwort schreiben
 
Dateianlage anfügen (KEINE vertraulichen Dokumente!)