Word Add-In nicht startbar, Laufzeitfehler beim Aktivieren

Waldemar F. hinzugefügt 13 Monaten her
beantwortet

Hallo,

ich versuche das Word Add-In in Word 2016 (Win 10 2004) zum Laufen zu bringen.

Nachdem ich die Vorlage hinzufüge und das AddIn aktiviere, sind beide unter den aktivierten Elementen gelistet, der Ribbon-Reiter fehlt.

Nach dem Neustart von Word (der sehr lange dauert) sind beide Elemente aber wieder deaktiviert.

Office Reparatur und manuelles de-/installieren vom Citavi AddIn habe ich bereits probiert.

Bei mehreren Versuchen nach obigem Schema, habe ich zwei Fehlerinfos erhalten:

1) Beim Laden des AddIns scheint ein Laufzeitfehler aufzutreten, im EventLog finden sich aber keine Details welcher. (Bild1)

2) Es besteht ein Problem mit "swissacademic.citavi.wordaddin.connect" (Bild2)

Grüße,

Waldemar

Antworten (1)

Foto
1

Guten Tag Waldemar


Ich bitte Sie, unser Diagnose-Programm auszuführen, das Sie unter https://www.citavi.com/wai-inspector finden. Das Programm prüft, welche Einstellungen die Installation oder das korrekte Laden des Add-Ins verhindern und schickt uns direkt das Ergebnis.

Freundliche Grüsse

Peter

Foto
1

Hallo Peter,

danke für die Rückmeldung. Ich habe das Diagnose Programm ausgeführt, die Ticket ID lautet: 150117.

Den Tipp aus einer ähnlichen Frage hier im Forum in der Registry den Wert für LoadBehavior von 2 auf 3 umzustellen habe ich versucht, dieser hat sich allerdings wieder auf 2 zurückgestellt.

(siehe https://help.citavi.com/topic/150002-literatur-lad-in-citavi-word-add-in-nicht-projekt-offnet-in-world-nicht-richtig)

Grüße,

Waldemar

Foto
1

Hallo Waldemar

Danke für den Prüfbericht. Das Problem liegt in der Office-Installation. Unser Prüf-Tool stellte fest:

There is a mismatch between the Word version in the registry and the one that actually starts.

Hatten Sie bereits versucht, die Office-Installation zu reparieren?

Freundliche Grüsse

Peter

Foto
1

Ja die Office Reparatur habe ich bereits ausgeführt.

Zur Info, nach Aktivieren der docm Vorlage und des AddIn wird von Word beim anschließenden Start im Splashscreen angezeigt, dass das AddIn geladen wird. Ist dann aber erstmal ein Dokument geöffnet sind beide deaktiviert. (siehe Bild 3 und 4).

Spielt es eine Rolle, dass es ein 64bit Office ist?

Grüße,

Waldemar

Foto
1

Hallo Waldemar, 64bit-Office ist nicht das Problem. Haben Sie ggf. SAntivirus auf dem System laufen? Das kann unser Prüftool nicht entdecken.

Freundliche Grüsse

Peter

Foto
1

Auf meinem PC läuft ein Sophos Endpoint Agent. SAntivirus ist nicht installiert.

Ich habe testweise alle Sophos Central-Richtlinien außer Kraft gesetzt und Elemente wie Echtzeit-Scans, User Control und Laufzeitschutz deaktiviert, am Word AddIn Verhalten hat dies allerdings nichts geändert.

Grüße,

Waldemar

Foto
3

Sophos ist unkritisch. Mühe machen bisher nur McAfee und SAntivirus. Ich bitte morgen, einen Kollegen aus der Entwicklung, auf Ihren Fall zu schauen.


Freundliche Grüsse

Peter

Foto
2

Hallo Peter,

gibt's evtl. ein Update zum aktuellen Stand? Falls ich noch etwas testen kann, einfach kurz Bescheid geben. :-)

Grüße,

Waldemar

Foto
1

Hallo zusammen,

möglicherweise gibt es einen Zusammenhang zwischen dem Laufzeitfehler und der auf dem System installierten Version des .NET Frameworks. Normalerweise sollte die jeweils aktuellste Version über die Windows-Updates verteilt werden. Sie kann aber auch manuell installiert werden.

Der Installer für die Version 4.8 des .NET Frameworks gibt es hier direkt zum Download: https://dotnet.microsoft.com/download/dotnet-framework/thank-you/net48-web-installer

Lässt sich das Citavi Word Add-In nach der Installation des Frameworks wie folgt aktivieren?


  1. Rufen Sie aus dem Word-Menü den Befehl "Datei" > "Optionen" > "Add-Ins" auf.
  2. Wählen Sie aus der Auswahlliste hinter "Verwalten" den Eintrag "COM Add-Ins" und klicken Sie auf "Gehe zu" (ab Word 2016: "Los").
  3. Setzen Sie ein Häkchen vor "Citavi Word Add-In [Versionsnummer]" und klicken Sie auf OK.
  4. Beenden Sie Word und starten Sie das Programm neu.

Viele Grüße

Sebastian

Foto
2

Hallo Sebastian,

ich bin Gestern noch über den Beitrag von Ferdinand gestolpert:

https://help.citavi.com/topic/149826-word-add-in-nach-update-verschwunden#comment-281476

Habe in dem Zuge mal mein Windows 10 auf 20H2 aktualisiert und danach alle verfügbaren Updates (Office etc.) installiert. .NET 4.8 war bei mir bereits installiert.

Leider auch hier kein Erfolg, das Problem besteht weiterhin.

Grüße,

Waldemar

Foto
1

Hallo Sebastian,

hier der versprochene erneute WAI-Inspector Check.

Ticket-ID: 151398

Grüße,

Waldemar

Foto
1

Hallo,

da es sich angeboten hat, hab ich bei der Office Neuinstallation direkt Office 2019 statt 2016 installiert und anschließend das AddIn entsprechend dieser Anleitung:

https://help.citavi.com/knowledge-base/article/add-in-nutzen-nach-office-upgrade

Leider immer noch kein Erfolg :-(

Hier die zugehörige WAI-Inspector ID: 151463

Grüße,

Waldemar

Foto
1

Hallo Waldemar,

bei mir hat sich dasselbe Problem ergeben. Ich bin jetzt auf Citavi 6.6 zurückgegangen und kann wieder ohne Einschränkungen arbeiten. Ist wahrschelich keine zufriedenstellende Antwort, aber vielleicht hilft es dir auch erstmal ;-)

Viele Grüße

Alina

Foto
1

Hallo Alina,

danke für den Tipp. Hab jetzt auch mal die v6.6 ausprobiert, aber da verhält es sich auf meinem PC leider genauso wie bei 6.7.

Für die Mitlesenden die es bei sich ausprobieren wollen, die alten Versionen gibt's unter:

https://help.citavi.com/knowledge-base/article/versionshistorie-citavi

Grüße,

Waldemar

Foto
1

Hallo Zusammen,


ich habe das selbe Problem. Sowohl WORD wie auch Citavi wurden jeweils neu installiert. Wenn ich in WORD in Datei --> Option --> Add-Ins gehe, sehe ich Citavi als inaktive Add-In Anwendung. Wenn ich nun unten Auf Verwalten COM-Add-Ins gehe und das Häkchen bei Citavi setze und Word neu starte. Startet das Add in wieder nicht. Wiederhole ich den Vorgang und und schaue bei den Add Ins nach, ist das häkchen wieder entfernt worden bei Citavi.


Liebe Grüße

Doreen


PS: ich habe auch nochmal die ältere Version von Citavi versucht, das Problem bleibt hier ebenfalls bestehen. Ich vermute eher ein Problem bei Word und nicht bei Citavi, da die Fehlermeldung aus Word heraus kam.

Foto
1

noch eine kleine Ergänzung mein Problem wurde wie folgt, dank dem Support von Citavi gelöst:

Ausgehend von Ihrem Prüfprotokoll empfehle ich diese Schritte:

  1. Rufen Sie aus dem Word-Menü den Befehl "Datei" > "Optionen" > "Add-Ins" auf.
  2. Wählen Sie aus der Auswahlliste hinter "Verwalten" den Eintrag "Deaktivierte Elemente" und klicken Sie auf "Gehe zu" (ab Word 2016: "Los"). Markieren Sie "Add-In: citavi word add-in [Nummer] (mscoree.dll)" und klicken Sie auf "Aktivieren".
  3. Starten Sie jetzt Word neu.

Ist das Add-In noch nicht sichtbar?

  1. Rufen Sie aus dem Word-Menü den Befehl "Datei" > "Optionen" > "Add-Ins" auf.
  2. Wählen Sie aus der Auswahlliste hinter "Verwalten" den Eintrag "COM Add-Ins" und klicken Sie auf "Gehe zu" (ab Word 2016: "Los").
  3. Setzen Sie ein Häkchen vor "Citavi Word Add-In [Versionsnummer]" und klicken Sie auf OK.
  4. Beenden Sie Word und starten Sie das Programm neu.


Es empfiehlt sich den PC komplett herunterzufahren und ein paar Minuten zu warten um ihn neu zu starten.

Liebe Grüße


Doreen

Foto
1

Hallo,

bei mir scheint es ein Rechteproblem zu sein, da das AddIn bei einem als Admin ausgeführten Word funktioniert, Word mit normalen Userrechten allerdings nicht.

Welche Rechte hier genau fehlen hab ich leider noch nicht rausgefunden.

Grüße,

Waldemar

Foto
1

Mittlerweile funktioniert das AddIn glücklicherweise auch bei mir. In meinem Fall war es eine besondere Fehlerquelle. Es sieht so aus als hätte eine Domänen Gruppenrichtlinie eine Effekt auf die Ausführung des AddIns:

Dank des Citavi Supports konnte aber auch hierfür ein Workaround geschaffen werden. Wenn bei euch also alle obigen Schritte nicht funktionieren und sich das AddIn wie bei mir verhält, dann probiert die Ausführung von Word als Admin. Taucht hier das AddIn nun auf, geht wie folgt vor damit auch der normale User es nutzen kann:

Aktivieren Sie unter Trust Center > Add-Ins die Option Anwendungs Add-Ins müssen von einem vertrauenswürdigen Herausgeber signiert sein. Starten Sie nun Word neu und öffnen Sie ein leeres Dokument.

Sie sollten nun am oberen Rand die gelbe Warnmeldung bezüglich der aktiven Inhalte sehen. Klicken Sie dort bitte *nicht* auf aktivieren, sondern auf den Textteil, um zu den Detail-Einstellungen zu gelangen. Im folgenden Dialog klicken Sie bitte auf die Schaltfläche mit dem Schild und dort auf die erweiterten Optionen. Hier sollten Sie die Möglichkeit haben für jedes Add-In dem Herausgeber dauerhaft zu vertrauen. Wählen Sie bitte diese Option für alle benötigten Add-Ins.

Anmerkung: Denkt dran, das AddIn natürlich wieder unter Vorlagen und COM-AddIns zu aktivieren.

Grüße,

Waldemar

Foto
1

Hallo Zusammen,


bei mir auch derselbe Sachverhalt. Auch nach Reparatur von MS Office und Neuinstallation von Citavi Version 6.7 keine Besserung. Hierbei wird Zitavi zwar in Optionen->Add-Ins unter "inaktiv" angezeigt jedoch gibt es beim Laden ein Timeout problem

auch unter Optionen -> Add-Ins -> COM-Add-Ins -> Los -> Citavi wird zwar mit dem Befehl "Beim Start laden" angezeigt, jedoch wird die Aktivierung des Kästchens auch mit Bestätigung per ok nicht gespeichert.


Habe daraufhin wie oben empfohlen Version 6.6 probiert. Läuft einwandfrei!

Optionen -> Add-Ins -> COM-Add-Ins -> Los -> Kästchen ist automatisch aktiviert.


Vielleicht ist hier eine eventuelle Schwachstelle der Version 6.7 identifiziert:

Bei selbem sonstigem Setup:


Version 6.7:

Optionen -> Add-Ins -> COM-Add-Ins -> Los -> Citavi wird zwar mit dem Befehl "Beim Start laden" angezeigt, jedoch wird die Aktivierung des Kästchens auch mit Bestätigung per ok nicht gespeichert.

Version 6.6:

Optionen -> Add-Ins -> COM-Add-Ins -> Los -> Kästchen ist automatisch aktiviert.


Vielleicht kann das zum Fixen des Bugs beitragen.


Beste Grüße


Sebastian

Foto
1

Hallo Sebastian, mögen Sie bitte anstelle von 6.6 besser 6.7.5 (= aktuelle Beta) installieren? Diese erhalten Sie hier:

https://www.citavi.com/de/news/articles/citavi-6-7-5-beta-verfuegbar

Freundliche Grüsse

Peter

Foto
2

Werte Citavi Nutzer und Entwickler,


Nach Langem hin und her deinstallieren sowie reparieren der Software, konnte ich durch diesen Beitrag das Problem lösen.

Die Ursache war das fehlende .NET Framework Version 4.8.

Der Hinweis plus Link zum Download kam von Sebastian P. (in diesem Beitrag ersichtlich).

Nach der Installation musste ich das Add In in den Word Optionen aktivieren (in den COM Add Ins den Haken setzen) und Word neu Starten.

Wichtig ist, dass diese Aktion auf einem Administrator Account durchgeführt wird.

Diesen kann man mittels cmd erstellen durch die EIngabe von "net user administrator /active:yes"

Auch hierbei beachten, dass cmd mit admin rechten gestartet wird z.b. indem man es mit gedrückter shift+Strg Taste doppelklickt.


Mein Dank gilt allen Beitragenden.


vG David

Diese Diskussion wurde geschlossen. Bitte erstellen Sie bei Bedarf einen neuen Beitrag.