Word Add in nach Update verschwunden

Christian M. hinzugefügt 30 Tagen her
beantwortet

Hallo zusammen,


nach dem Update auf Version 6.7 lädt das Add-in in MS Word leider nicht mehr.


Was ich probiert habe:


1) Programm im Installer "ändern" -> add-in deninstalliert und anschließend wieder installiert

2) Citavi deinstalliert, MS Office repariert, Citavi erneut installiert

3) in der registry den Wert bei loadbehavior Wert auf 3 gesetzt (geht immer wieder zurück auf 2 von allein)

4) in MS Word unter Optionen, Add-ins, Verwalten der COM-Add-Ins Häkchen beim CITAVI Add in setzen, der verschwindet immer wieder. Unter den Optionen wird das Citavi Word Add-In 6.7.0.0 als inaktiv angezeigt.


Ich nutze MS Windows 10 Enterprise 2016 LTSB mit MS Office Professional Plus 2016


Vielen Dank im Voraus für eure Hilfe & beste Grüße

Christian

Kommentare (15)

Foto
1

...ich habe eben noch das Diagnose-Tool genutzt (http://www.citavi.com/wai-inspector) und das Ergebnis zugesandt.

Der Reihenfolge nach habe ich auch alle hier https://www.youtube.com/watch?v=JpRO4opz3NA&feature=youtu.be aufgezählten Lösungsversuche ausprobiert, leider ohne Erfolg.

Foto
2

Bei mir leider genau das gleiche. Vor dem Update hat alles funktioniert....

Foto
1

Ich hatte dasselbe Problem. Bei mir hat es letztendlich geholfen einmal Citavi zu deinstallieren und dann neu zu installieren

Foto
1

Ich habe dasselbe Problem. Habe soeben Citavi deinstalliert und neu installiert - keine VERÄNDERUNG. Der Word Add-in lässt sich nicht aktivieren noch starten. Was nun? Bitte um Hilfe

Foto
Foto
1

Es hat bisher leider nichts geholfen. Gestern hatte ich einen sehr freundlichen live-support, auch da konnten wir den Fehler nicht finden. Ich habe noch eine Mail bekommen mit Lösungsversuchen, die ich hier gern teile (ich hoffe das ist in Ordnung), bei mir hat es aber nicht geholfen:

1) .NET-Installation reparieren

Um die .NET-Installation (das ist die technische Basis von Microsoft, auf die Citavi zugreift) zu reparieren, führen Sie bitte das Fix-it-Tool aus, das Microsoft für solche Fälle hier bereitgestellt hat: http://www.microsoft.com/en-us/download/details.aspx?id=30135

2) Windows nach defekten Systemdateien suchen lassen

Klicken Sie mit der linken Maustaste auf die Startschaltfläche "Start" (unten links).

  1. Tippen Sie: cmd.exe
  2. In der Trefferliste erscheint: Command Prompt (App)
  3. Klicken Sie mit der rechten Maustaste auf "Command Prompt".
  4. Wählen Sie "Als Administrator ausführen".
  5. Ein DOS-Fenster erscheint. Tippen Sie: sfc.exe /scannow
  6. Bestätigen Sie die Eingabe mit Enter. Die Selbstreparatur von Windows startet.

3) Windows nach fehlenden Updates suchen lassen

  1. Klicken Sie mit der linken Maustaste auf die Startschaltfläche "Start" (unten links).
  2. Tippen Sie: Updates
  3. Wählen Sie: "Nach Updates suchen"
  4. Starten Sie den Computer neu.

Möglicherweise konnten Windows Updates nicht installiert werden. Das wirkt sich auch auf die Installation von Citavi aus. Bitte lösen Sie darum das Update-Problem zuerst. Wie das funktioniert, erklärt Microsoft hier: https://support.microsoft.com/de-ch/help/10164/fix-windows-update-errors

4) Office reparieren

  1. Klicken Sie mit der rechten Maustaste auf die Startschaltfläche "Start" (unten links).
  2. Klicken Sie auf "Apps und Features".
  3. Klicken Sie auf Ihr Office-Produkt.
  4. Klicken Sie auf "Ändern ".
  5. Wählen Sie im Fenster "Wie möchten Sie Ihre Office-Programme reparieren?" die Option "Onlinereparatur > Reparieren".
  6. Folgen Sie den Anweisungen auf dem Bildschirm zur Ausführung der Reparatur.

5) Citavi neu installieren

  1. Klicken Sie mit der rechten Maustaste auf die Startschaltfläche "Start" (unten links).
  2. Klicken Sie auf "Apps und Features".
  3. Klicken Sie auf "Citavi 6".
  4. Klicken Sie auf "Deinstallieren".
  5. Laden Sie das aktuelle Setup von https://www.citavi.com/download herunter.
  6. Installieren Sie das Setup.

Ich werde das System einmal neu aufsetzen. Ich berichte, ob es dann funktioniert.

Foto
1

Bei mir hat nun dieser Weg die Lösung gebracht:

https://help.citavi.com/topic/word-add-in-fehlt-in-word

Foto
1

Ja, das haben wir auch probiert & half in meinem Fall leider nicht.

Foto
1

Hallo zusammen, ich scheine dasselbe Problem zu haben. Seit dem Update auf Version 6.7 geht mein Word-AddIn nicht mehr. Deinstallation des AddIns über den Software-Weg sowie die oben beschriebene Herangehensweise führen zwar dazu, dass ich den Citavi-Reiter und das Programm aktivieren kann, aber meine Literatur erscheint nicht. Ich kann 1000mal in Word auf "Citavi starten" klicken, es blinkt nur das separate Citavi-Fenster, aber in Word tut sich nichts. Schließe ich Word und öffne es wieder, ist das Citavi-AddIn wieder deaktiviert und der Reiter weg. So macht es keinen Sinn.


Kann ich die alte Version (6.6) irgendwo runterladen? Bis das gepatcht ist, muss ich jetzt auf dem Laptop arbeiten...

Foto
1

Ergänzung - habe 6.6 runtergeladen und auf dem betreffenden PC installiert. Geht auch nicht mehr, gleiches Problem wie vorher, ich kann also aktuell nicht weiterarbeiten.

Foto
2

Hallo, ich habe wirklich alle(!) Lösungsvorschläge, die man in diesem Zusammenhang finden kann, durchprobiert und sicherlich einen kompletten Arbeitstag verschwendet. Dazu gehörte die Neuinstallation von Citavi genauso wie das Neuaufsetzen von Office. Es hat wirklich nichts geholfen. Ich konnte mit der Version 6.6 letztendlich weiterarbeiten. [Link entfernt] Das Add-In musste jedoch selbst in Word nochmal aktiviert und dann Word neugestartet werden. Sofort hat er das Add-In trotzdem nicht geladen.


VG

Foto
2

Hallo Christian,

vielen Dank für Ihre Nachricht.

Wir haben nun ein Indiz, woran es liegt, dass bei Ihnen das Word Add-in von Citavi 6.7 nicht funktioniert - Sie verwenden Windows 10 Enterprise 2016 LTSB. In dieser abgespeckten Windows-Version kommt es anscheinend zu einem Laufzeitfehler, wenn das Add-in geladen werden soll. Leider gibt es nicht nur eine, sondern mehrere LTSB-Versionen. Wir prüfen noch, wie wir die Inkompatibilität beheben können.

Viele Grüße

Susanne

Foto
1

Hallo,


Ich hab ein paar eigene Erlebnisse mit ähnlichen Problemen und vielleicht hilft das, dem Problem auf die Spur zu kommen.

1. Ich verwende auch Windows 10 LTSB 2016, mit Office 365 (Account meiner Hochschule) und seit heute ging das Citavi-Addon in Word nicht mehr. Ich habe auch alle Problemlösungsvarianten (Citavi neu installieren, Office neu Installieren, registry anpassen) probiert, und es führte nichts zu einer Lösung. Jedoch könnte auch ein aktuelles Word Update (auf Version 2010) für das Problem verantworlich sein. Bis vor ein paar Tagen (vor dem Word Update) lief alles noch einwandfrei.

2. Ich habe eine VM zu Testzwecken (Windows 10 LTSC 2019), auf der noch Word 365 in der Version 2009 installiert ist. Ich installierte Citavi 6.7 und das Add-in läuft problemlos.


Ich kann jetzt den Einfluss des neueren Windows nicht ausschließen, aber da es bis vor ein paar Tagen noch problemlos lief, denke ich mal, das Word die Probleme verursacht. Wäre super, wenn das Team dieses Problem bald beheben könnte.


Vielen Dank,

Ferdinand

Foto
3

Hallo, zusammen

Möglicherweise hängt das Problem mit dem .NET Framework zusammen. Das Update auf die aktuelle Version 4.8 sollte zwar über die Windows-Updates ausgerollt werden, lässt sich aber auch manuell nachinstallieren. Der direkte Download-Link zum Installer lautet: https://dotnet.microsoft.com/download/dotnet-framework/thank-you/net48-web-installer

Lässt sich das Citavi Add-In auf folgende Art aktivieren, wenn diese Framework-Version installiert wurde?


  1. Rufen Sie aus dem Word-Menü den Befehl "Datei" > "Optionen" > "Add-Ins" auf.
  2. Wählen Sie aus der Auswahlliste hinter "Verwalten" den Eintrag "COM Add-Ins" und klicken Sie auf "Gehe zu" (ab Word 2016: "Los").
  3. Setzen Sie ein Häkchen vor "Citavi Word Add-In [Versionsnummer]" und klicken Sie auf OK.
  4. Beenden Sie Word und starten Sie das Programm neu.

Viele Grüße

Sebastian

Foto
2

Hallo Sebastian,


Es geht wieder. Juhu. Danke für den Lösungsweg mit dem .NET Update.


Falls es den anderen hilft, hier noch die Schritte, welche ich durchgeführt habe:

1. Installation des .NET Updates (download vom Link oben)

1.a. Während der Installation das Beeneden von verschiedenen Programmen erzwingen (es kam so ein Dialog)

2. Nach erfolgreicher Installation Windows Neustarten

3. Windows Updates --> Installation neuer Updates

4. Windows Neustarten

5. Word öffnen und in "Optionen" -> "Add-ins" -> "Verwalten: COM-Add-ins" das Citavi Word Add-in aktivieren.


Vielleicht hat es auch nur in meinem speziellen Fall geholfen, aber ich hoffe, dass es be den anderen auch bald wieder gehen wird.


Viele Grüße,

Ferdinand

Foto
1

Hallo zusammen,


irgendwie ist mein gestriger Kommentar gelöscht. Ich wollte mich noch bedanken für den tollen Support von Sebastian und Susanne, bei mir hat es sich exakt genauso verhalten wie bei Ferdinand - es funktioniert also wieder!!

Beste Grüße


Christian

Foto
1

Hallo Christian,

vielen Dank für Ihre freundliche Rückmeldung - das Lob und den Dank reiche ich gerne an Sebastian weiter.

(Es gibt in diesem Thread ein Posting von Ihnen, das gestern um 13:04 Uhr verfasst wurde und das eigentlich korrekt angezeigt werden müsste.)

Viele Grüße

Susanne

Foto
Foto
1

Hallo Sebastian,

habe mal mein Windows 10 auf 20H2 aktualisiert und danach alle verfügbaren Updates (Office etc.) installiert. .NET 4.8 war bei mir bereits installiert.

Leider auch hier kein Erfolg, das Problem besteht weiterhin.


Grüße,

Waldemar

Foto
1

Hallo, Waldemar

Ich bitte Sie, nochmal unser Diagnose-Programm auszuführen, das Sie unter https://www.citavi.com/wai-inspector finden. Das Programm prüft, welche Einstellungen die Installation oder das korrekte Laden des Add-Ins verhindern und schickt uns direkt das Ergebnis.

Viele Grüße

Sebastian

Foto
1

Hallo Sebastian,


ich hab versehentlich im falschen Topic geschrieben. Unter dem eigentlichen Ticket

https://help.citavi.com/topic/150070-word-add-in-nicht-startbar-laufzeitfehler-beim-aktivieren

gibt's alle Infos inkl. dem WAI-Inspector Ergebnis vor dem Update.


Ich werde dort den erneuten Check posten, sonst wird das vll. etwas unübersichtlich.


Grüße,

Waldemar

Foto
Foto
1

Hallo zusammen,

vielen Dank für das große Engagement an den Support! Die Installation von version 6.6 hat nicht geholfen, aber der Link von Sebastian zum Installer brachte die Lösung. Zunächst funktionierte es nicht, aber wie bei Ferdinand bot auch mir Windows anschließend ein Update an - und nun klappt es wieder!

Vielen Dank & beste Grüße

Christian

Foto
1

Moin Jungs,

Ich hatte auch das Problem (Win 10 1903 Enterprise)

Ein laden des Addons per "Optionen" -> "Add-ins" -> "Verwalten: COM-Add-ins" kann ich zwar machen, jedoch wird dann das Projekt nicht in Word angezeigt.

hab mal den Inspector laufen lassen, da stand drin:

HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins\SwissAcademic.Citavi.WordAddIn.Connect\LoadBehavior

Value: 0


Hab den mal auf "3" geändert wie sich das gehört und schon lief das Ganze wieder.


Vielleich hilft dem einen oder anderen das weiter.


Gruss Leo

Foto
1

Hallo Leo

Wir haben hierzu auch diesen FAQ-Artikel:

https://help.citavi.com/knowledge-base/article/fehlerhafter-eintrag-in-der-windows-registry

Freundliche Grüsse

Peter

Foto