Issue with MLA 7th edition, in-text citation Option 2 without page range

Mélanie Y. shared this question 9 months ago
Need Answer

Hello,


I am citing the title of a chapter from an edited volume without a page range using the MLA 7th ed citation style. It was the best workaround I could find to insert this particular citation without the field being formatted in an undesirable way.


I inserted the reference (let's title it "Auf der Suche") as an in-text citation, and made sure to check "Option 2" and "no parentheses." I expected to obtain the following format:


In "Auf der Suche" (In the Search, 2008), we learn that... (Note: I boldfaced the reference field, the rest is just typed text).


However, I obtain:


In "Auf der Suche," (In the Search, 2008), we learn that... (Please note the comma after the chapter title.)


Could you help me get rid of this comma? I tried to see if the issue would persist if I switched to the MLA 8th edition, but it does not.


Thank you very much!

Mélanie

Comments (3)

photo
1

Hello Mélanie,

Thank you for your question.

"Option 2" is intended to display the short title als well as the page range. MLA 7 does require a comma between the short title (citation key in Citavi) and the page range, however MLA not.

To display only the short title, you would have to modify the citation style. Please add a new template to the Rule set in-text citation and choose the condition "Citation has "/option 3" or "/opt 3".

Duplicate the component "Citation key" and edit it by double clicking on and remove the comma in the text element. Drag and drop this new component in your new template.

Save the changes you have made to the style and also select it in your Word document. Then, please choose "Option 3" in the Word Add-in.

However, the easiest option would be to type the citation key manually in Word.

Kind regards,

Jana

photo
1

Hi Jana,


I tried to follow the steps you describe, but I must be doing something wrong because all references cited with "Option 2" have their comma disappear. I am not sure if this information is enough for you help me. Otherwise I can type the citation key manually in Word, but this may become tedious because Citavi regularly updates its fields. Whatever is typed in manually in the bibliography automatically generated by Citavi will disappear.


Otherwise, while inspecting my document, I noticed a similar issue. I am citing an online newspaper article that has no author and page range. The article's title is "Bedauersnwerte Auserwählte" (cited from the internet which have no authors and no page number. When I cite it, it appears as (with a comma hanging).


("Bedauernswerte Auserwählte,")


Is there anything I can do about it? Except manually edit it, but I would then run in the issue described earlier.


Thank you very much,

Mélanie

photo
1

Hi Mélanie,

Did you duplicate the component "Citation key" for the new template?

It sounds like the template with "Option 2" and the template with "Option 3" are using the same component without comma.


Please note that when you insert a citation from your Citavi project into your document using the Citavi Word Add-In, it will be inserted in a Word content control.

These fields become grey when you click them. After inserting such a field you cannot edit it manually, for example by adding page numbers.

This also applies to the bibliography, which Citavi also inserts as a field. Each time the document is refreshed, any manual changes will be overwritten.

This means that you can only type manually outside of the fields, in your text body.

In order to determine the cause of the problem newspaper issue, we kindly ask you to send us a sample document (max. 3 pages). First, please link a new Word document to your Citavi project, and second, please insert via the Word Add-In only those titles which have given you problems. Please send us the Word document via our website at http://www.citavi.com/transfer. Under Message, please enter the following ticket number: #103613

Please also send us your modified citation style which is saved under \Documents\Citavi 6\Custom Citation Styles\

Thank you and kind regards,

Jana