Citation in Latex citation is undefined

marius.thiry.mt@gmail.com shared this question 57 days ago
Answered

I use latex with citavi for a few weeks now, and everything worked well.

Today I tried to add 2 new book-sources. The Sources are in the bibliography-file, but when I try to cite them, there only appears

[?]

and I get an error message "citation in line 15 is undefined".

All the other citations still work properly. Only the 2 new ones make thes problems.


Edit: I forgot to mention: The 2 new inserted also don't appear at the bibliography of my script

Has anyone an idea how this can be solved?

Comments (7)

photo
1

Hello,

Thank you for your message.

Which LaTeX package did you choose for your publication?

Kind regards

Jana

photo
1

Hello Jana,

For the publication I use BibTex

My other Informations:

I work with TexStudio.

Also I use the KOMA-Script

here are the packages I use:

%\documentclass[12pt,twoside]{scrreprt}

\documentclass[paper=a4,11pt,twoside,open=any,numbers=noenddot]{scrbook}

\KOMAoption{listof}{entryprefix}

\usepackage{amssymb}

\usepackage[T1]{fontenc}

\usepackage[ngerman]{babel}

\usepackage{graphicx}

\graphicspath{{images/}}

\usepackage[a4paper,width=150mm,top=25mm,bottom=25mm,bindingoffset=6mm]{geometry}

\usepackage{textcomp}

\usepackage{fancyhdr}

\pagestyle{fancy}

\fancyhead{}

\fancyhead[R]{\thepage}

\fancyfoot{}

\fancyfoot[R]{\thepage}

\usepackage{float}

\usepackage[utf8]{inputenc}

\usepackage[T1]{fontenc}

\setlength{\parindent}{0em}

\usepackage{eurosym}


\usepackage{times}

\usepackage[fleqn]{amsmath}


\renewcommand*{\listoflofentryname}{Abb.}

\raggedbottom


Kind Regards


Marius

photo
1

Dear Marius,

Thank you for your fast reply.

As our LaTeX expert is currently on holiday, may I ask you for your patience until his return at the beginning of September? Other users might be able to help you in the meantime.

Kind regards

Jana

photo
1

Dear Jana,

thank you for your fast answer.

I need the answer very soon, since the deadline for my bachelor thesis is in September. But I think there is no other possibility than waiting, since your expert is on holiday.

I really hope some other users can help me in the meantime.

Anyway, thank you for your answers and for trying to help me.

Kind regards

Marius

photo
1

Dear Marius,

Other LaTeX users have reported similar problems here (although in German). I hope this helps if you use a translation service.

Kind regards

Jana

photo
1

Dear Jana,

Thank you very much for your help.

I am very happy to tell you, that the problem solved itself. I have no idea why, but I just noticed, that it works well now. Every cite is how it should be. I did not change anything according to the citation. So I am a little confused, but also happy.

I hope this doesn't appear again.

Thank you again for your help

Kind Regards

Marius

photo
1

Dear Marius,

Great, thank you very much for the good news!

Kind regards,

Jana