Best practice to reduce filesize of cloud project

Ingmar H. shared this question 15 months ago
Answered

Hi,

I just realized that my main cloud project is lager than 5 GB therefore violating the fair use agreement. I started to try to reduce the size by eliminating duplicates, but that's rather tedious and not very effective. What is the best way to reduce file size without splitting the project?

Ideally I would like to filter by some threshold size value (like > 200 MB) and then sort by file size in order to identfy the titles that really carry impact - I just have no clue, how to do this...

Any suggestions welcome!

Comments (1)

photo
1

Hi,

we're working on a good solution here. In the meantime please use the attached macro for identifying references with large attachments. Please save it somewhere on your disk.

Please note that this macro will only run with Citavi Beta 6.3.6 or newer, not with the current release 6.3.0.0.

Here's how you run it:

1) Open the macro editor: Tools > Macro editor

2) In the macro editor select File > Open and open the macro.

3) Select Tools > References > Add

4) In the file selection dialog, please navigate to C:\Program Files (x86)\Citavi 6\bin and select the file Microsoft.WindowsAzure.Storage.dll and click Open. Click OK.

5) In line 33 of the macro you can specify the size of what in your opinion constitutes a large attachment (in MB). It's currently set to 100.

6) Click Run.

The macro will output all attachments and their respective sizes in the output area of the macro editor and will create a selection of all references that have attachments exceeding the size set in line 33.

Best regards

Sebastian

photo
1

Great - thanks a lot for this fast response!

I will test-drive and report back, but need time to install the beta-version (and decide which computer ist least critical for this action....).


Greetings!

photo
1

OK, the provided solution works without any problems - but skimming a larger project turns out to be very tedious, as it requires lots of repetitive steps. In working through my project I realized that part of my large library are very large ebooks. For some of those the publisher had a neewer file with dramatically reduced file size, others were available in a new edition (mostly also with reduced file size), but for quite a proportion there was no chance to reduce the file size (not even when trying different options in Acrobats tools). Result so far: I reduced my cloud project by roughly 1.5 GB, but I'm still in excess of 5 GB...Then I realized that I often have ebooks in several versions (editions) and now I wonder what the easiest way might be to identify all of the older versions. I would then move those to a different, local project and thus try to further reduce my cloud project. Any suggestions as to best do this?

photo
1

Hi, Ingmar

I'm not entirely sure if there is a feasible way of achieving this. I assume that the different versions of the books are each attached to the corresponding reference in Citavi? If so, the only way to perhaps solve this is locally caching each of the files and trying to read some kind of version info from the file itself. There is no way to make sure that such info is actually present in the file.

Best regards

Sebastian

photo
1

I understand, if you need Cloud access + features, this probably isn't ideal.

  • However, if you choose: File menu, This project menu, Save A Copy of this project menu?
  • Then you can save local. (Which is what I wondered? If I wanted a project to leave Cloud & be local.)
  • [ Aside: THINK that does this now? for me. ]
  • Dialog Box: Create local project copy.
  • As POST: Is it possible to export all our your Citavi project data? says.
  • Then using SQLLite Personal version, you can read your data?

Sorry, if doesn't work. I was looking for a technical way to gather some statistics on your Database.

If it could help you out?

  • If they have macros, we can write? I don't know.
  • Or best, we stay out of it?

Cheers Ingmar, Dave


PS: (You likely have seen it Ingmar.) There is a "save locally attachments" option, in the File menu, (*) This Project, (*) Properties, (*) Attachments TAB.

photo