Author names in text with IEEE citation style

Nico L. shared this question 3 months ago
Answered

Hello, everyone,


for a publication I want to use the citation style "Proceedings of the IEEE". Now - at least as far as I know - this style of quoting looks as follows when the authors are mentioned in the text:


"...end of the line for my research [13]."

"This theory was first put forward in 1987 [1]."

"Scholtz [2] has argued that..."

"Several recent studies [3], [4], [15], [16] have suggested that...."

"For example, see [7]."

I would like to write like the bold marked text. But if I click on "Insert with options" and then on "Names only", only brackets are inserted and not the names of the authors of the publication.


Why is that?

I look forward to your answers.

Comments (3)

photo
2

Hi Nico

I have modified the style. Now, when you add a new source from Citavis Word Add-in with the option "/option 1", the name is added.

Regards,

Peter

photo
1

Hi Peter,

thanks for your help. It works fine! Could you please also edit the style "IEEE Editorial (German)". I got the same issue here.

Cheers,

Nico

photo
1

Hi Nico,

IEEE Editorial (German) has been updated, too.

Kind regards,

Peter

photo
1

Thanks Peter.

I just noticed that there is no space between the author's name and the parenthesis with the number.

So it looks like this: Burkhalter et al.[18] instead of Burkhalter et al. [18]

Kind regards

Nico

photo
1

Hi Nico,

We have just published the corrected version of the style. Please restart Citavi if you are connected to the Internet so that Citavi can download the new style version from our server to your computer. Thank you for pointing out the problem.

Kind regards,

Peter

photo
1

Hi Peter,

thank you for changing the style. Did you also change the German version of IEEE, i.e. "IEEE Editorial (German)"?

In my document, it still looks like this: Lehnert und Rühr[5]

Kind regards,

Nico

photo
1

Hi Nico

Are you still using Citavi 5? If not: Please delete the IEEE style in the folder %localappdata%\Swiss Academic Software\Citavi 6\Settings\CitationStyles -I suspect that you have not received the update.

Kind regards,

Peter

photo
1

Hello Peter,


thank you, it worked perfectly.

I have (unfortunately) another question: If I add exact page numbers to the IEEE citation style, it works fine. Examples:

[20, S. 215]

[20, S. 215-220]

But if I use the "f." and "ff." which are commonly used in German publications, then no "S." is inserted anymore. Example:

[20, 215 ff.]

I insert the "ff." directly into the field with the page number.

Kind regards

Nico

photo
1

Hello Nico, please check solution 3 in this article:

https://help.citavi.com/knowledge-base/article/unerwartete-stil-ergebnisse

Kind regards,

Peter

photo