Template doesn't apply if previous reference is in a multiple citation

Przemysław K. shared this question 13 months ago
Need Answer

Hello. I have another problem with custom styles.

I am changing a style called "Przeglad Historyczny" so it has shortened references if they are cited again. So instead of eg:

Michał Auch, Wczesnośredniowieczne naczynia szkliwione z terenu Małopolski, wyd. 1., Wydawnictwo Instytutu Archeologii i Etnologii Polskiej Akademii Nauk, Warszawa 2016, s. 11–13


We have this when it is mentioned again:

Michał Auch, Wczesnośredniowieczne naczynia..., s. 11–13


I have made a template that is basically:

[Author] [Custom field for short titles] [, S. quotation range] with: [previous reference is in a previous footnote (but other footnotes without references may appear between those footnotes)].

And it basically works, except for one situtation. It seems the above condition doesn't work if the earlier footnote was in a multiple citation.


So for example if my first reference to the book was in a multiple citation, then every other reference to the same book will NOT be shortened. It will always show in the basic/default template. This is not something I want. I want every next reference to the same book be shortened even if the reference is alone in the footnote or as a multiple citation.

Currently to address that I had to add 3 more templates, each with [previous reference is part of a multiple citation, /at beginning/in second or later position/at end] but it feels like a terrible solution.


Is there a more graceful way to address that? Frankly I would be perfectly happy if there was at least a condition [previous reference is part of a multiple citation] that doesn't check its exact position [beginning/middle/end]. But it seems there isn't such condition.


EDIT: Okay actually even "[previous reference is part of a multiple citation [...] ]" doesn't seem to fix the problem. In this case for some reason every reference in a multiple citation gets shortened even though it wasn't referenced before... I am honestly clueless how to deal with it.

Replies (1)

photo
1

I believe that the condition that would allow you to have the shortened reference is "Reference was cited in a previous footnote". It's further down the list of conditions than the one that you have set in your custom option. See my attached image for the correct checkbox. Then, you should uncheck the "Previous reference is in a previous footnote" option.

I'm not sure what the condition that you have set does, but the "Reference was cited in a previous footnote" option has always worked for me, whether the first use of that source is a multiple citation or not.

Leave a Comment
 
Attach file (NO confidential documents!)