Is there any method to change the font in all existing knowledge items?

David L. shared this question 15 months ago
Need Answer

I've finished most of my research and am now organizing my knowledge items. I'm finding that the default font in Citavi is a bit difficult for my old eyes to read. Is there any way to change the font in all of the knowledge items at once?

Replies (1)

photo
1

Thanks, but I have no idea at all on what to do with that. Any suggestions?

photo
2

https://www1.citavi.com/sub/manual6/en/index.html?executing_macros.html

I can't explain it better than the manual. To be on the safe side, I have also uploaded the macro as an attachment. Important: always make a copy of the project first.

photo
1

Thanks. I'll give it a shot.

photo
1

I realize that this is a dumb question, but need a bit more help. I've saved the macro as a ".cs" file on my computer, but the Citavi macro editor doesn't recognize it. I suspect it's because Windows has classified it as a text file, rather than a "cs" file. Any suggestions?

photo
2

OK. But there are no stupid questions, only sometimes stupid answers.

1. open macro editor

2. ctrl+O (open) search for the *.cs in the file system

3. in line 45 "fontSize = 9" set the desired font size

4. "Compile" → no errors should appear

5. then execute (run)


PS. For my bumpy English I ask for your indulgence. I use Deepl for security

photo
1

#2 is the problem. I can't find the file using Citavi's macro editor, even though it's clearly there using Windows Explorer. When I saved it, Windows told me that it was saving it as a ".cs.txt" file and not allowing me to change that. However, in Win Explorer, it's listed with only the ".cs" ending but categorized as a Text File.

photo
1

Oh, and your English is great! What is your native language, if you don't mind me asking.

photo
2

Ah, the problem is that the file name extensions are not displayed. Please tick and then rename *.cs.txt to *.cs

78562c5609b39c26c0f9955a6fc52a48

German is my native language.

photo
1

Thanks. That solved that problem. But now that I'm running the macro, it's changing everything back to Citavi's default font, Segoe UI, 9 pt. I had assumed (incorrectly) that it would give me the chance to select the font I want. How do I do that? I would like to change everything to Verdana, 12 pt.

Thanks again for your help and patience.

photo
3

a4d696e93643e36320415c8deee68bbc

photo
1

Thanks, Pragmarius, for writing that macro! I used the macro for increasing the font size of the abstract. It worked - but the change is not saved when the project is closed. When I re-open the project, the font is back to the previous size. Do I need to change an extra setting for the change to be saved?

photo
1

There was a bug in some Citavi versions. Which version are you using?

photo
1

Sorry, should have provided that straight away: I'm using version 6.14.0.0

photo
1

I stay with 6.8 for many reasons and it does not have this error.

photo
1

Good to know, thanks!

photo
1

Pragmarius, are you aware of any method to go back to an earlier version of Citavi?

photo
1

I have written some instructions in German, but they should be understandable if you let Google translate them.

https://help.citavi.com/topic/187246-losung-bei-problem-mit-6-10

photo
Leave a Comment
 
Attach file (NO confidential documents!)