Automatically import keywords from sources

Nora B. shared this question 2 months ago
Need Answer

Hi,


Having just switched back to Citavi after using Zotero for a while, I am generally very happy with how well Citavi imports PDFs and their metadata.

One thing I am missing terribly however, is the function to automatically import keywords for articles. These can be fetched either from PDF metadata or a DOI. It's a real hassle to add keywords manually when I'm importing large amounts of articles at once. I'd love for Citavi to at least give me those that are already associated with the article, I can always add my own later! :) I'm terrible at organising my data, and the automatic keyword collection made it much easier and more "tempting" for me to actually use this functionality.

Any chance this could be enabled as an option in the future?

Comments (1)

photo
1

Hi,

Welcome back to Citavi!

Citavi does already import the keywords for your when you have activated this option under Tools > Options > Search > Include keywords (both for the Online search and the ISBN search).

With this add-on you can update reference details in case keywords are missing.

Kind regards,

Jana

photo
1

Hi,


Thank you for the quick reply. The add-on did the trick.


Weirdly, the function to include keywords was enabled for both online sources and ISBN sources, but keywords had only been applied to 4 of the 39 articles that I added prior to posting. Half of those were keywords I added myself before giving up (...to two articles). All articles were added to the project using the Citavi Picker and by sending PDFs to Citavi. I added a few random articles now, and they included keywords. So they must have somehow gone missing on the way from the Picker to Citavi prior to installing the add-on.. :-)


Thank you for your help!

photo
1

Hi Nora,

Thanks for your reply.

Could you please let us know the DOIs of some of the articles for which the Citavi Picker did not import keywords in the first place?

Thanks and kind regards,

Jana

photo
Leave a Comment
 
Attach file (NO confidential documents!)