How to insert ONLY the page number after a citation?

Carlos A. shared this question 19 months ago
Need Answer

Hi!!!!

I'm working with APA 6th in Spanish, where you need a type of citation like this:

According to Smith (2016):

"Lorem Ipsum etc etc etc" (p. 123)

My question is: How do I insert ONLY that page number after the citation with the Citavi Word Add-In?

Any help appreciated!

Replies (3)

photo
1

Hello,

Unfortunately, it is not possible to "split" citations, to receive an output of the pages separated from author and year or to insert only the pages. The request for this function is already on our internal list, but we can not yet say when this will be implemented.

There are two ways to receive the output you wish:


1. You insert author and year "Smith (2016)" by using the option "Insert advanced" > "Person (Year)" via Citavis Word Add-In and add the pages "(p. 123)" manually after the citation.

2. You create a new template within the citation style, containing only the pages that can be selected in Word as needed.

Problem: the APA-Style is very complex, with numerous document types and many pre-existing templates and conditions. Therefore, the adjustment would not be easy or quickly feasible.

I would therefore advise, even if the procedure is not optimal, the solution mentioned under 1.

Best regards,

Anne

photo
1

In this thread in the German-language Citavi forum, it's recommended to edit your style and create a 'Format option: Option 1' workaround: https://help.citavi.com/topic/nur-seitenzahl-am-ende-des-zitats


What's not a good idea is to insert the citation twice: once as "Person (Year)" as recommended in 1. and then once more after the quotation, this time including a page number – and then to manually delete everything before the page number. As you can find on https://citavi.com/edit , if a change in Citavi makes a field update happen, all manual changes are lost.


(I need this for CMOS Author-Date style, you can see it all over https://owl.purdue.edu/owl/research_and_citation/chicago_manual_17th_edition/documents/201802161242_717_10.pdf for example.)


In the style editor, I had to go click an "In-text citation", go to Template -> New at the top, set the condition to 'Citation has option "1"', and duplicate the component ", Quotation page range" to remove the prefixed ", " from the duplicate, because otherwise all other page range quotations were wrecked.

It's a bit counter-intuitive altogether, but works fine now.

photo
1

I thought it would be more helpful to add a picture to explain my instructions.


7296dc0d21d33508c8c8def8f2cd346c

Leave a Comment
 
Attach file (NO confidential documents!)