Google login: "Couldn't sign you in"

The login window opens. After clicking the "Google" login button and entering your Gmail address, you receive the following error message:

The text is:

Couldn't sign you in

This browser or app may not be secure. 

Try using a different browser. If you’re already using a supported browser, you can refresh your screen and try again to sign in.

Cause

You're using Citavi version 6.8 or older. You tried to log in using the Google login option with your Gmail credentials. As of the end of June 2021, Google no longer supports authentication via a browser control embedded in desktop applications.

Solution

Please install the update to the current beta version of Citavi (download here). With Citavi 6.9.1 and newer, login is done via a separate browser window. All previous login options are available there, including authentication via Google.

After logging in, please click the "Open Citavi" button in the separate browser window - then you can choose between the options "Remember me on this computer" or "When exiting Citavi log out of account" as usual. You can then close the separate browser window.

If you do not have admin rights, use the following workaround:

  1. On the Welcome Screen, click the person icon in the upper right.
  2. Enter your Citavi Account login name and password. Please do not select the "Google" option on the login screen.

If you have forgotten your Citavi password or have not yet chosen one: Please go to https://www.citavi.com/login and click there on "Forgot password". This will allow you to set a new password.

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